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A detailed HTTP 403.14 error message occurs when you go to a specific InternalSite URL in a Forefront Unified Access Gateway 2010 environment


View products that this article applies to.

Symptoms

You use your web browser to go to a specific InternalSite URL in a Microsoft Forefront Unified Access Gateway (UAG) 2010 environment. If you go to the website from an external location, you receive a HTTP 403.14 error message that contains detailed information.

For example, you use your web browser to go to the following internal site that resembles the following:

https://trunk_IP_address/uniquesig1234567890abcdef1234567890/uniquesig0/InternalSite/


Note Replace the trunk_IP_address placeholder by using the trunk IP address, and replace the uniquesig placeholder by using the appropriate values.

In this case, you receive a HTTP 403.14 error message that contains detailed information.

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Cause

This problem occurs because Internet Information Services (IIS) on the Forefront UAG server is configured to return detailed error messages for requests that originate from LocalHost. When the Internet Server API (ISAPI) filter in Forefront UAG intercepts a client request that is destined for the InternalSite, the filter creates new HTTP requests originating from itself. Therefore, the InternalSite application sees that the request originates from LocalHost, and if an error condition occurs, a detailed error page is returned. The ISAPI filter in Forefront UAG then returns the detailed error page to the Internet client "as is."

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Resolution

To resolve this problem, install Service Pack 4 for Microsoft Forefront Unified Access Gateway 2010.

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Workaround

To work around this problem, follow these steps:
  1. Open IIS Manager as an administrator.
  2. Double-click Error Pages for Default Web Site.
  3. Click Edit Feature Settings.
  4. Change the Error Responses setting to Custom Error Pages from the default setting, Detailed errors for local requests and custom error pages for remote requests.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

See the terminology Microsoft uses to describe software updates.

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Keywords: kbnotautohotfix, kbqfe, kbfix, kbexpertiseinter, kbsurveynew, kbbug, kb

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Article Info
Article ID : 2909356
Revision : 1
Created on : 1/7/2017
Published on : 11/27/2013
Exists online : False
Views : 330