Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Mouse pointer stutters or freezes when you play certain games in Windows 8.1 and Windows Server 2012 R2


View products that this article applies to.

Symptoms

When you play certain desktop games in Windows 8.1 or Windows Server 2012 R2, the mouse pointer freezes or stutters.

Notes
  • Other issues in Windows 8.1 and Windows Server 2012 R2 have symptoms that resemble the symptoms that are described in this article. To fix these issues, go to the following Microsoft Knowledge Base articles:
    2907016 Mouse input in some games is incorrectly scaled on high-DPI devices
    2907018 Button clicks for internal touchpads and pointing sticks are not responsive while or shortly after the keyboard is used
  • For a list of games that are known to experience this issue, see the "Games that this update applies to" section.
  • The mouse pointer may also stutter or freeze when you run applications other than games.

↑ Back to the top


Cause

This issue occurs because Windows 8.1 introduced changes to mouse input processing for low-latency interaction scenarios. Therefore, games respond to mouse inputs differently in Windows 8.1 than in earlier versions of Windows.

↑ Back to the top


Resolution

Update information

Note After you install this update and then run an application that this update targets, mouse input is changed throughout the system. Therefore, this update may cause adverse effects on the performance and battery life of the computer.

How to obtain this update

Update rollup 2903939
To resolve this issue, install update rollup 2903939. For more information about how to obtain this update rollup package, click the following article number to go to the article in the Microsoft Knowledge Base:
2903939 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 update rollup: December 2013
 
Microsoft Download Center
The following files are available for download from the Microsoft Download Center:
Operating system Update
All supported x86-based versions of Windows 8.1 Download icon Download the package now.
All supported x64-based versions of Windows 8.1 Download icon Download the package now.
All supported x64-based versions of Windows Server 2012 R2 Download icon Download the package now.
For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.
Games that this update applies to

This update resolves this issue in the following games:
  • Call of Duty: Black Ops
  • Call of Duty: Black Ops - Multiplayer
  • Call of Duty: Black Ops II
  • Call of Duty: Black Ops II - Multiplayer
  • Call of Duty: Black Ops II - Zombies
  • Call of Duty: Ghosts - Single Player
  • Call of Duty: Ghosts - Multiplayer
  • Call of Duty: MW2
  • Call of Duty: MW2 - Multiplayer
  • Call of Duty: MW3
  • Call of Duty: MW3 - Multiplayer
  • Call of Duty: MW
  • Call of Duty: MW - Multiplayer
  • Counter Strike: Global Offensive
  • Counter Strike: Source
  • Deus Ex: Human Revolution
  • Deus Ex: Human Revolution Director's Cut
  • Hitman Absolution
  • Hitman Sniper Challenge
  • Half Life 2
  • Metro 2033
  • Portal
  • Portal 2
  • Tomb Raider
  • World of Warcraft
Note We are adding support for additional games to this update.

How to extend this update to other games

The update also includes an extension mechanism to resolve this issue in additional games. If you encounter this issue in games that are not listed in the "Games that the update applies to" section, click the Fix it button to extend the update coverage.

 


If it does not work, try the steps in the Let me fix it myself section if necessary.
Let me fix it myself

Important
Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.

 
  1. Click Start, type regedit.exe in the Start Search box, and then press Enter.
  2. Click Yes if the User Account Control dialog box is displayed.
  3. Browse to the following folder:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

    Note
    If the Layers key does not exist, right-click AppCompatFlags, click New, click Key, and then type Layers to create the key.
  4. Create a new registry entry for the game. To do this, right-click Layers, click New, click String Value, type the full path of the game’s executable file in the box, and then press Enter.
  5. Right-click the value, and then click Modify. In the Value data field, type NoDTToDITMouseBatch, and then press Enter.
  6. Click OK to confirm the change. The registry key in Registry Editor should resemble the entry in the following screen shot.
    The registry key in Registry Editor should resemble the entry in the following screen shot

     
  7. Open an elevated Command Prompt window. To do this, click Start, type cmd.exe in the Start Search box, right-click cmd.exe in the search results list, and then click Run as administrator.
  8. Run the following command at an elevated command prompt:
    
    Rundll32 apphelp.dll,ShimFlushCache 
Important You should apply the registry key mechanism only to games that are known to be affected by this issue. If you set this registry key outside the scope of the games that require this registry key, the performance of the computer battery may be affected. Specifically, do not apply the registry key mechanism to long-running background and notification area processes.

Note If you are a game developer or you provide support for a game, and you experience this issue in your games, apply this solution. If this solution resolves the issue, and the game is not included in the "Games that this update applies to" list, you can provide a registry update for the game.

For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, go to the following Microsoft website:

Prerequisites

To apply this update, you must be running Windows 8.1 or Windows Server 2012 R2.

Restart requirement

You must restart the computer after you apply this update.

Update replacement information

This update does not replace a previously released update.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Workaround

If the game provides a raw input option, you can select this option to work around this issue.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Third-party information disclaimer
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

↑ Back to the top


Keywords: kb, kbfix, atdownload, kbexpertiseadvanced, kbsurveynew

↑ Back to the top

Article Info
Article ID : 2908279
Revision : 4
Created on : 4/17/2018
Published on : 4/17/2018
Exists online : False
Views : 816