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You cannot use a WSD printer or scanning device in Windows Server Core


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Symptoms

You cannot use a Web Services on Devices (WSD) printer or a scanning device that is locally attached to the operating system (through a USB port, for example) in a Server Core environment in Windows Server.

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Cause

This issue occurs because the Server Core environment does not support WSD printers or Windows Image Acquisition (WIA) scanning.

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Resolution

To resolve this issue, you must install the Desktop Experience optional feature to enable support for WSD printers and scanning in Windows Server. To use Windows PowerShell to install the Desktop Experience feature, follow these steps.

Notes
  • In the example commands in this procedure, it is assumed that the Windows Image file is located at d:\sources\install.wim.
  • Some complexities occur when you use a Windows Image file that is located on a network share. This is because network resources are accessed by using the machine account and do not impersonate the logged-in user when you are using the Server Manager cmdlets. If you experience difficulties as you perform these steps, copy the .wim file to a local disk, and then try again.
  1. Locate the Windows Image file (*.wim) that is included in your Windows installation media.
  2. Determine the index number for a server that has a GUI image (for example SERVERDATACENTER, not SERVERDATACENTERCORE). To do this, run the following PowerShell command:
    Get-WindowsImage -ImagePath d:\sources\install.wim 
    Note You must use the Windows image that corresponds to the edition of Windows that you are running. However, you must not use any Windows image that ends in “CORE” because those images do not contain the files that are required to install Desktop Experience.
  3. To install the Desktop Experience feature, run the following PowerShell command:
    Install-WindowsFeature Desktop-Experience –Source wim:d:\sources\install.wim:4 –Restart 
    Note If you omit the -Source parameter, Windows tries to download the feature through Windows Update. If the installation is successful, the server restarts.

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More Information

The lack of support for scanning devices and WSD printers in the Server Core environment also prevents Server Certification testing of the scanner devices.

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Keywords: kbexpertiseinter, kbexpertiseadvanced, kbsurveynew, kb

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Article Info
Article ID : 2908152
Revision : 1
Created on : 1/7/2017
Published on : 11/6/2013
Exists online : False
Views : 305