Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Internal server error exception when users perform a search in SharePoint


View products that this article applies to.

Symptoms

When users perform a search in a Microsoft SharePoint environment, they receive the following error message:

Internal server error exception:

Troubleshoot issues with Microsoft SharePoint Foundation

Additionally, the following critical exception may be written to the ULS log of the SharePoint Web front-end server: 
Process: OWSTIMER.EXE (0x1CE0)

Product: SharePoint Foundation

Category: Topology

EvendID: 8031

Message:
An exception occurred while updating addresses for connected app {eaf6c00c-cc3f-460e-8bf2-ad9b991ea6ea_aa16845d-045a-46bc-bbc6-d701ff13950d}. The uri endpoint information may be stale. System.InvalidOperationException: The requested application could not be found at Microsoft.SharePoint.SPTopologyWebServiceApplicationProxy.ProcessCommonExceptions(Uri endpointAddress, String operationName, Exception ex, SPServiceLoadBalancerContext context) at Microsoft.SharePoint.SPTopologyWebServiceApplicationProxy.ExecuteOnChannel(String operationName, CodeBlock codeBlock) at Microsoft.SharePoint.SPTopologyWebServiceApplicationProxy.GetEndPoints(Guid serviceId) at Microsoft.SharePoint.SPConnectedServiceApplicationAddressesRefreshJob.Execute(Guid targetInstanceId) bf94139a-66f8-4aab-af31-406a5ebb6db9

↑ Back to the top


Cause

This issue occurs when the Search service application proxy is associated with a web application but is not associated with any Search service applications in the farm. 

↑ Back to the top


Resolution

To allow users to search without receiving this error message, reassociate the web application with a valid Search service application proxy. A valid Search service application proxy will be associated with a Search service application in the Manage service applications option. To do this, follow these steps:
  1. Open Central Administration.
  2. Click Manage web applications.
  3. Select the affected web application.
  4. On the ribbon, click Service Connections.
  5. Under Configure Service Application Associations, select the valid Search service application proxy check box.

↑ Back to the top


Keywords: kbprosharepoint, kbdiagnostics, kb

↑ Back to the top

Article Info
Article ID : 2908052
Revision : 1
Created on : 1/7/2017
Published on : 12/26/2013
Exists online : False
Views : 466