Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error "0x80090004 (NTE_BAD_LEN)" occurs when you try to sign in to Windows Live Messenger in Windows 8.1 or Windows Server 2012 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows 8.1 or Windows Server 2012 R2. 
  • You install Windows Live Messenger by installing Windows Live Essentials with Chinese Simplified language. 
  • You start Windows Live Messenger, and then you try to sign in.  
In this scenario, the sign-in attempt fails. Additionally, you receive an error message that resembles the following: 
0x80090004 (NTE_BAD_LEN) 

↑ Back to the top


Cause

This issue occurs because code mishandling occurs during session key encryption.

↑ Back to the top


Resolution

Update information

To resolve this issue, install update rollup 2903939. For more information about how to obtain this update rollup package, click the following article number to view the article in the Microsoft Knowledge Base:
2903939 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 update rollup: December 2013

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kb, kbqfe, kbfix, kbsurveynew, kbexpertiseadvanced

↑ Back to the top

Article Info
Article ID : 2906900
Revision : 1
Created on : 1/7/2017
Published on : 12/10/2013
Exists online : False
Views : 297