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Print jobs that use the LPR protocol aren't displayed in the print queue


View products that this article applies to.

Symptoms

You have a print server that's running Windows Server 2012 R2 or Windows Server 2012. When you print documents by using the Line Printer Remote (LPR) protocol, the print jobs don't appear in the print queue, and the documents are never printed.

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Cause

This problem occurs because the version 4 (or Type 4) printer drivers don't support LPR printing.

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Resolution

To fix this issue in Windows 8.1 or Windows Server 2012 R2, install update 2955164. For more information about update 2955164, click the following article number to view the article in the Microsoft Knowledge Base:
2955164 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 update rollup: May 2014
To fix this issue in Windows 8 or Windows Server 2012, install the hotfix that is described in this article.

After the fix is installed, LPR Print Jobs can be sent to V4 Printer Queues. The LPR Print Job needs to be marked as binary format (for example: Postscript).

This can be done with the -o Option in the LPR.exe Tool.

Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows 8 or Windows Server 2012 installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 8 and Windows Server 2012 file information and notes

Important Windows 8 and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    VersionProductMilestoneService branch
    6.2.920 0.20 xxxWindows 8 and Windows Server 2012RTMLDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 8 and Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 8
File nameFile versionFile sizeDateTimePlatform
Lpdsvc.dll6.2.9200.2086742,4961-Nov-133:51x86
For all supported x64-based versions of Windows 8 and of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Lpdsvc.dll6.2.9200.2086750,1761-Nov-134:11x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Additional file information

Additional file information for Windows 8 and for Windows Server 2012

Additional files for all supported x86-based versions of Windows 8
File nameX86_7d7ba230187cdc46a9d06d80d5589056_31bf3856ad364e35_6.2.9200.20867_none_1fcc77130d28b7cf.manifest
File versionNot Applicable
File size712
Date (UTC)01-Nov-2013
Time (UTC)14:06
PlatformNot Applicable
File nameX86_microsoft-windows-p..ing-lpdprintservice_31bf3856ad364e35_6.2.9200.20867_none_88eb32035bb6f36c.manifest
File versionNot Applicable
File size12,396
Date (UTC)01-Nov-2013
Time (UTC)05:05
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows 8 and of Windows Server 2012
File nameAmd64_7262c17319c1a3f6515f1688750c3766_31bf3856ad364e35_6.2.9200.20867_none_2e193f6585ac0a3d.manifest
File versionNot Applicable
File size716
Date (UTC)01-Nov-2013
Time (UTC)14:06
PlatformNot Applicable
File nameAmd64_microsoft-windows-p..ing-lpdprintservice_31bf3856ad364e35_6.2.9200.20867_none_e509cd87141464a2.manifest
File versionNot Applicable
File size12,400
Date (UTC)01-Nov-2013
Time (UTC)06:21
PlatformNot Applicable

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References

For more information about the Type 4 drivers and the LPR protocol, see the "New and changed functionality" and the "Server Manager Information" sections of the Print and Document Services Overview topic on the Microsoft TechNet website.

Learn about the terminology that Microsoft uses to describe software updates.

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbbug

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Article Info
Article ID : 2905035
Revision : 1
Created on : 1/7/2017
Published on : 1/14/2016
Exists online : False
Views : 484