Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

RPC Client Access service crashes if you add "Signed By" or "Send From" column in Outlook online mode


View products that this article applies to.

Symptoms

Assume that you’re running Microsoft Outlook in online mode in a Microsoft Exchange Server 2010 environment. You add the Signed By or Send From column from All Mail fields in the Outlook View settings. In this situation, the Microsoft Exchange RPC Client Access service (Microsoft.Exchange.RpcClientAccess.Service.exe) crashes on the Client Access server. Additionally, the following event is logged in the Application log:

↑ Back to the top


Cause

This issue occurs because the view cache is left in an inconsistent state when you add the Signed By or Send From column in the Outlook View settings.

↑ Back to the top


Resolution

To resolve this issue, install the following update rollup:
2917508 Description of Update Rollup 5 for Exchange Server 2010 Service Pack 3

↑ Back to the top


Workaround

To work around this issue, either use Outlook in cached mode or make sure that you do not show the Signed By or Send From column in the View Settings.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseinter, kb

↑ Back to the top

Article Info
Article ID : 2904459
Revision : 1
Created on : 1/7/2017
Published on : 2/25/2014
Exists online : False
Views : 162