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Some USB devices do not recharge in Windows 8.1


View products that this article applies to.

Symptoms

When you connect a USB device to a computer that is running Windows 8.1, the device is suspended and does not recharge.

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Cause

This issue may occur because of power management improvements that are introduced in Windows 8.1. These improvements help reduce power consumption and extend the battery life of mobile computers. If the USB device presents itself as a Human Interface Device (HID) and there is no app accessing the device, Windows suspends the device.

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Resolution

To resolve this issue, install an updated device driver. To check whether an updated driver is available, follow these steps:
  1. Open the Windows Update item in Control Panel. To do this, swipe in from the right edge of the screen, and then tap Search. Or, point to the upper-right corner of the screen, and then click Search.
  2. In the search box, type Windows Update.
  3. Tap or click Settings, and then tap or click Install optional updates.
  4. Tap or click Check for updates, and then wait while Windows looks for the latest updates for your computer.
If updates are found, tap or click Install updates.

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Workaround

To work around this issue, you can disable the Enhanced Power Management settings for the device that does not recharge.

Note This setting helps reduce power consumption and extend the battery life for mobile computers. If you disable the Enhanced Power Management setting for the device, you can expect that power consumption by the device will increase and that battery life will be shortened if the device is connected to a mobile computer. 

To disable the Enhanced Power Management settings for the device, follow these steps.

Important Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.

  1. Connect the USB device to the computer.
  2. In Control Panel, open the Device Manager item. To do this, swipe in from the right to open the charms, tap or click Search, and then type device manager in the search box. Or, type device manager at the Start screen, and then tap or click Device Manager in the search results.
  3. To display the list of connected HIDs, tap or click the arrow next to Human Interface Devices.

    Note The device may be listed by name or generically as "USB Input Device."
  4. In the device list, right-click or press and hold the entry for the device that is not charging, and then click Properties.


    Note If this entry is labeled as "USB Input Device" instead of the device name, and if there are multiple "USB Input Device entries, follow these steps to determine which entry is the correct one:
    1. Disconnect the problem device from the computer.
    2. Right-click each USB Input Device entry, and then click Properties to view the device description and details. Note each connected device.
    3. Reconnect the problem device.
    4. Examine each USB Input Device entry again to determine which one is new and, therefore, represents the problem device.
  5. In the Properties dialog box for the problem device, tap or click the Details tab.
  6. In the list under Property, select Device Instance Path, and then note the ID information. For example, note the following:
    USB\VID_1234&PID_5678\0A1B2C3D
    Note This line is a combination of the following ID numbers:
    • Vendor ID (VID)
    • Product ID (PID)
    • Instance ID
  7. Start Registry Editor. To do this, swipe in from the right to open the charms, tap or click Search, type regedit.exe in the search box. Or, type regedit.exe at the Start screen, and tap or click regedit in the search results.
  8. In the navigation pane, find the registry key that corresponds to the problem device. To do this, follow these steps:
    1. Tap or click the arrow next to the HKEY_LOCAL_MACHINE folder to expand it.
    2. Expand SYSTEM.
    3. Expand CurrentControlSet.
    4. Expand Enum.
    5. Expand USB.
    6. Locate the folder whose name contains the VID and PID that you noted in step 6 (for example, locate VID_1234&PID_5678), and then expand that folder.
    7. Expand the folder that matches the Instance ID from step 6.
    8. Tap or click Device Parameters.
  9. In the details pane, right-click or press and hold EnhancedPowerManagementEnabled, and then click Modify.
  10. Change the Value data to 0, and then tap or click OK.
  11. Exit Registry Editor.
The problem device should now recharge correctly.

If you have to enable the Enhanced Power Management setting again for the device after you install an updated driver, follow the same steps in this section except that, in step 10, change the Value data to 1.

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Keywords: kbexpertiseinter, kbexpertisebeginner, kbsurveynew, kb

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Article Info
Article ID : 2900614
Revision : 3
Created on : 4/17/2018
Published on : 4/17/2018
Exists online : False
Views : 242