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Data Deduplication garbage collection job does not work as expected in Windows Server 2012


View products that this article applies to.

Symptoms

Consider the following scenario:

  • You install the Data Deduplication feature on a Windows Server 2012-based computer.
  • You enable Data Deduplication on a large-size data volume.
  • You create a garbage collection job. However, you do not add the "–full" parameter.

In this situation, the garbage collection job does not work as expected. Therefore, data chunks that are no longer referenced are not cleaned up. 

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Cause

This issue occurs because a garbage collection job that does not use the "–full" parameter uses a Bloom filter to detect data chunks that are no longer referenced. However, because the Bloom filter is too small, it does not correctly detect data chunks.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012.

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You might have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2012 file information notes
Important Windows 8 and Windows Server 2012 hotfixes are included in the same packages.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.2.920 0.20 xxxWindows Server 2012RTMLDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows RT, Windows 8, and Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Ddppipeline.dll6.2.9200.208462,001,9209-Oct-1322:42x64
Ddpscan.dll6.2.9200.20842585,2169-Oct-1322:42x64
Ddpstore.dll6.2.9200.208462,256,3849-Oct-1322:42x64



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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2012
Additional files for all supported x64-based versions of Windows Server 2012
File propertyValue
File nameAmd64_7a9775f1c00837353080044a28358ae7_31bf3856ad364e35_6.2.9200.20846_none_c2dabb4114be7dab.manifest
File versionNot applicable
File size706
Date (UTC)10-Oct-13
Time (UTC)8:31
PlatformNot applicable
File nameAmd64_microsoft-windows-dedup-pipeline_31bf3856ad364e35_6.2.9200.20846_none_b2dc5a1c6389f966.manifest
File versionNot applicable
File size15,120
Date (UTC)10-Oct-13
Time (UTC)1:43
PlatformNot applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

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Article Info
Article ID : 2897997
Revision : 1
Created on : 1/7/2017
Published on : 11/13/2013
Exists online : False
Views : 171