Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Data loss occurs when a Windows Server 2012-based computer that has the data deduplication feature enabled crashes


View products that this article applies to.

Symptoms

Assume that you have a Windows Server 2012-based computer that has the data deduplication feature enabled on some volumes. When the computer crashes, data loss occurs unexpectedly. 

↑ Back to the top


Cause

This issue occurs because a reparse point is set before all the deduplication data recalls are completed. The data deduplication feature recalls a section of a file to write to by using a writing process. Then, the feature flushes the written data from the recalled section to a reparse point. However, when lots of writing processes are running at the same time, the flush may be performed before all the recalls are completed. Therefore, when the computer crashes, the data that was written to the unflushed recalls is lost.

↑ Back to the top


Resolution

To resolve this issue, install update rollup 2889784, or install the hotfix that is described in this article.

Update information

For more information about how to obtain update rollup 2889784, click the following article number to view the article in the Microsoft Knowledge Base:
2889784 Windows RT, Windows 8, and Windows Server 2012 update rollup: November 2013
Hotfix information
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.





Windows Server 2012 file information notes
Important Windows 8 hotfixes and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    VersionProductMilestoneService branch
    6.2.920 0.16 xxxWindows Server 2012RTMGDR
    6.2.920 0.20 xxxWindows Server 2012RTMLDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Dedup.sys6.2.9200.16731419,67205-Oct-201306:37x64
Dedup.sys6.2.9200.20842419,67207-Oct-201301:01x64


↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Additional file information

Additional file information for Windows Server 2012

Additional files for all supported x64-based versions of Windows Server 2012
File propertyValue
File nameAmd64_2ecbc148ca47d3bfdc3f487e5afc5711_31bf3856ad364e35_6.2.9200.20843_none_5bca5174765562d8.manifest
File versionNot applicable
File size704
Date (UTC)07-Oct-2013
Time (UTC)19:01
PlatformNot applicable
File nameAmd64_785429e2874fcd5497dc98668a4ece4c_31bf3856ad364e35_6.2.9200.16731_none_15de0325fe8f0190.manifest
File versionNot applicable
File size704
Date (UTC)07-Oct-2013
Time (UTC)19:01
PlatformNot applicable
File nameAmd64_microsoft-windows-dedup-filter_31bf3856ad364e35_6.2.9200.16731_none_610e504ee1564f28.manifest
File versionNot applicable
File size7,824
Date (UTC)05-Oct-2013
Time (UTC)06:48
PlatformNot applicable
File nameAmd64_microsoft-windows-dedup-filter_31bf3856ad364e35_6.2.9200.20843_none_618f1dc1fa7a3d91.manifest
File versionNot applicable
File size7,824
Date (UTC)07-Oct-2013
Time (UTC)02:14
PlatformNot applicable
File namePackage_1_for_kb2897097_bf~31bf3856ad364e35~amd64~~6.2.1.0.mum
File versionNot applicable
File size1,769
Date (UTC)07-Oct-2013
Time (UTC)19:01
PlatformNot applicable
File namePackage_1_for_kb2897097~31bf3856ad364e35~amd64~~6.2.1.0.mum
File versionNot applicable
File size2,480
Date (UTC)07-Oct-2013
Time (UTC)19:01
PlatformNot applicable
File namePackage_for_kb2897097_rtm_bf~31bf3856ad364e35~amd64~~6.2.1.0.mum
File versionNot applicable
File size1,426
Date (UTC)07-Oct-2013
Time (UTC)19:01
PlatformNot applicable
File namePackage_for_kb2897097_rtm~31bf3856ad364e35~amd64~~6.2.1.0.mum
File versionNot applicable
File size1,445
Date (UTC)07-Oct-2013
Time (UTC)19:01
PlatformNot applicable
File nameUpdate-bf.mum
File versionNot applicable
File size1,558
Date (UTC)07-Oct-2013
Time (UTC)19:01
PlatformNot applicable

↑ Back to the top


Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

↑ Back to the top

Article Info
Article ID : 2897097
Revision : 1
Created on : 1/7/2017
Published on : 11/13/2013
Exists online : False
Views : 188