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Plug and Play Manager stops working when you wake a computer from sleep in Windows


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You restart a Windows 7 Service Pack 1 (SP1), Windows Server 2008 R2 SP1, Windows 8, or Windows Server 2012-based computer.
  • You put the computer into Sleep mode.
  • You wake the computer.
In this scenario, Plug and Play Manager may stop working. Additionally, if you plug in a USB device or a Secure Digital (SD) card, the USB device or SD card is not listed in the device manager nor in the "Devices with Removable Storage" section of My Computer.

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Cause

This issue occurs because Portcls.sys incorrectly handles the error from audio drivers.

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Resolution

Update information

To resolve these issues, install update rollup 2889784. For more information about how to obtain this update rollup package, click the following article number to go to the article in the Microsoft Knowledge Base:
2889784 Windows RT, Windows 8, and Windows Server 2012 update rollup: November 2013
Hotfix information
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7 SP1
  • Windows Server 2008 R2 SP1
  • Windows 8
  • Windows Server 2012

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You may be prompted to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows RT, Windows 8, and Windows Server 2012 file information
Important Windows 8 and Windows Server 2012 hotfixes are included in the same packages.

Notes
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.2.920 0.16 xxxWindows RT, Windows 8, and Windows Server 2012RTMGDR
    6.2.920 0.20 xxxWindows RT, Windows 8, and Windows Server 2012RTMLDR
For Windows RT
File nameFile versionFile sizeDateTimePlatform
Drmk.sys6.2.9200.1672090,11221-Sep-201302:37Not applicable
Drmkaud.sys6.2.9200.164335,63211-Oct-201204:30Not applicable
Portcls.sys6.2.9200.16723194,56024-Sep-201322:17Not applicable
Sysfxui.dll6.2.9200.16433340,99211-Oct-201204:50Not applicable
Wmalfxgfxdsp.dll6.2.9200.164331,144,96811-Oct-201205:10Not applicable
For all supported x86-based versions of Windows 8
File nameFile versionFile sizeDateTimePlatform
Drmk.sys6.2.9200.1643383,45611-Oct-201204:39x86
Drmkaud.sys6.2.9200.164335,12011-Oct-201204:40x86
Portcls.sys6.2.9200.16723219,13624-Sep-201322:19x86
Sysfxui.dll6.2.9200.16433336,89611-Oct-201205:07x86
Wmalfxgfxdsp.dll6.2.9200.164331,262,74411-Oct-201205:18x86
Drmk.sys6.2.9200.2053483,45611-Oct-201204:44x86
Drmkaud.sys6.2.9200.205345,12011-Oct-201204:44x86
Portcls.sys6.2.9200.20833218,11224-Sep-201322:19x86
Sysfxui.dll6.2.9200.20534336,89611-Oct-201205:12x86
Wmalfxgfxdsp.dll6.2.9200.205341,262,74411-Oct-201205:43x86
For all supported x64-based versions of Windows 8 and of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Drmk.sys6.2.9200.16433111,61611-Oct-201205:18x64
Drmkaud.sys6.2.9200.164335,63211-Oct-201205:19x64
Portcls.sys6.2.9200.16723288,76824-Sep-201322:18x64
Sysfxui.dll6.2.9200.16433370,17611-Oct-201205:45x64
Wmalfxgfxdsp.dll6.2.9200.164331,636,67211-Oct-201207:02x64
Drmk.sys6.2.9200.20534111,61611-Oct-201205:17x64
Drmkaud.sys6.2.9200.205345,63211-Oct-201205:17x64
Portcls.sys6.2.9200.20833285,69624-Sep-201322:18x64
Sysfxui.dll6.2.9200.20534370,17611-Oct-201205:44x64
Wmalfxgfxdsp.dll6.2.9200.205341,636,67211-Oct-201207:11x64
Windows 7 and Windows Server 2008 R2 file information
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

Notes
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    1.18xxx
    Windows 7 and Windows Server 2008 R2SP1GDR
    6.1.760
    1.22xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Drmk.sys6.1.7601.1827081,40825-Sep-201301:48x86
Portcls.sys6.1.7601.18270177,15225-Sep-201301:15x86
Drmk.sys6.1.7601.2246581,40825-Sep-201301:52x86
Portcls.sys6.1.7601.22465177,15225-Sep-201301:19x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Drmk.sys6.1.7601.18270116,73625-Sep-201302:11x64
Portcls.sys6.1.7601.18270230,40025-Sep-201301:32x64
Drmk.sys6.1.7601.22465116,73625-Sep-201302:15x64
Portcls.sys6.1.7601.22465230,40025-Sep-201301:36x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Portcls.sys6.1.7601.18270605,69625-Sep-201301:00IA-64
Portcls.sys6.1.7601.22465605,69625-Sep-201301:02IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew

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Article Info
Article ID : 2892932
Revision : 1
Created on : 1/7/2017
Published on : 11/13/2013
Exists online : False
Views : 228