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A file copy operation fails when files or folders have long paths in Windows Explorer


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7 Service Pack 1 (SP1), or Windows Server 2008 R2 Service Pack 1 (SP1).
  • You use Windows Explorer to try to copy files or folders in order to paste them into some other folder.
  • The files or folders that you copy have paths that exceed the maximum allowable path length.

In this scenario, the behavior of the copy operation is unreliable and fails because of the length of the file or folder path. Additionally, you may experience one of the following symptoms:
  • The copy operation fails and generates a message that states that the path (file name) is too long. The message also suggests that you shorten the file name and try to copy again.
  • The copy operation does not start. In this case, no message is generated.
  • The copy operation starts, copies a few files or folders, and then fails without generating a message.

This problem may prevent some files or folders from being copied. You may not realize the the problem occurred if you do not receive an error message. Different symptoms may occur, depending on how the files are selected for copying.

Note This problem can also occur when you try to copy files or folders from Volume Shadow Copy Service snapshots if the file or folder length in the snapshot exceeds the maximum path length.

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Cause

This problem occurs because of an issue in how Windows handles the long-path errors.

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Resolution

To resolve this issue for Windows 8.1, Windows Server 2012 R2, Windows 8, andWindows Server 2012, install the update rollup.
To resolve this issue for Windows 7 and Windows Server 2008 R2, install the hotfix that is described in this article.

Update information for Windows 8.1, Windows Server 2012 R2, Windows 8, and Windows Server 2012

To resolve this issue, install the update rollup that is dated April 2012 or November 2014.

Hotfix information for Windows 7 and Windows Server 2008 R2

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Service Pack 1 for Windows 7 or Windows Server 2008 R2 installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 7 and Windows Server 2008 R2 file information and notes

Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    VersionProductSR_LevelService branch
    6.1.760
    1.
    22xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, extremely important issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Shell32.dll6.1.7601.2250312,875,77606-Nov-201308:00x86
For all supported x64-based versions of Windows 7 and Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Shell32.dll6.1.7601.2250314,177,79206-Nov-201308:51x64
Shell32.dll6.1.7601.2250312,875,77606-Nov-201308:00x86
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Shell32.dll6.1.7601.2250321,196,80006-Nov-201307:58IA-64
Shell32.dll6.1.7601.2250312,875,77606-Nov-201308:00x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_5d28b9c19d39486a1a7e115506261602_31bf3856ad364e35_6.1.7601.22503_none_8fa29bae8b68a3a7.manifest
File versionNot Applicable
File size695
Date (UTC)06-Nov-2013
Time (UTC)14:55
PlatformNot Applicable
File nameX86_microsoft-windows-shell32_31bf3856ad364e35_6.1.7601.22503_none_6ec3e88889548dc6.manifest
File versionNot Applicable
File size1,059,457
Date (UTC)06-Nov-2013
Time (UTC)10:12
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows 7 and Windows Server 2008 R2
File nameAmd64_228d6e6efa0f144b0e3153891fddec59_31bf3856ad364e35_6.1.7601.22503_none_3f69116101f5cf33.manifest
File versionNot Applicable
File size699
Date (UTC)06-Nov-2013
Time (UTC)14:56
PlatformNot Applicable
File nameAmd64_ab8a5a310911f0a583d4c1b8a0642dba_31bf3856ad364e35_6.1.7601.22503_none_400593ee3163c592.manifest
File versionNot Applicable
File size1,040
Date (UTC)06-Nov-2013
Time (UTC)14:56
PlatformNot Applicable
File nameAmd64_microsoft-windows-shell32_31bf3856ad364e35_6.1.7601.22503_none_cae2840c41b1fefc.manifest
File versionNot Applicable
File size1,058,443
Date (UTC)06-Nov-2013
Time (UTC)09:16
PlatformNot Applicable
File nameWow64_microsoft-windows-shell32_31bf3856ad364e35_6.1.7601.22503_none_d5372e5e7612c0f7.manifest
File versionNot Applicable
File size1,054,916
Date (UTC)06-Nov-2013
Time (UTC)08:14
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_bba4409f672758cfdaf3e6e43606e4d6_31bf3856ad364e35_6.1.7601.22503_none_d273341408e6cde2.manifest
File versionNot Applicable
File size1,038
Date (UTC)06-Nov-2013
Time (UTC)14:55
PlatformNot Applicable
File nameIa64_microsoft-windows-shell32_31bf3856ad364e35_6.1.7601.22503_none_6ec58c7e895296c2.manifest
File versionNot Applicable
File size1,058,441
Date (UTC)06-Nov-2013
Time (UTC)08:22
PlatformNot Applicable
File nameWow64_microsoft-windows-shell32_31bf3856ad364e35_6.1.7601.22503_none_d5372e5e7612c0f7.manifest
File versionNot Applicable
File size1,054,916
Date (UTC)06-Nov-2013
Time (UTC)08:14
PlatformNot Applicable

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References

Learn about the terminology Microsoft uses to describe software updates.

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbbug

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Article Info
Article ID : 2891362
Revision : 1
Created on : 1/7/2017
Published on : 11/11/2014
Exists online : False
Views : 358