Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: Incorrect Performance Monitor values when queried from a .NET Framework app in Forefront Threat Management Gateway 2010


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You use a Microsoft .NET Framework application to query Performance Monitor counters in Microsoft Forefront Threat Management Gateway 2010.
  • The application queries counters for the Forefront TMG Firewall Service.

In this scenario, all the values that are returned by the counters appear incorrect when they're compared to the values that are returned in Performance Monitor.

For example, this problem occurs when the application queries the Active UDP Connections counter. In this situation, the counter always returns 300 regardless of what the correct value is.

↑ Back to the top


Cause

This problem occurs because the Performance Monitor definitions for the Forefront TMG Firewall Service are incorrect.

↑ Back to the top


Resolution

To resolve this problem, install Rollup 4  for Forefront Threat Management Gateway 2010 Service Pack 2.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


References

Learn about the terminology Microsoft uses to describe software updates.

↑ Back to the top


Keywords: kbnotautohotfix, kbqfe, kbfix, kbexpertiseinter, kbbug, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 2890549
Revision : 1
Created on : 1/7/2017
Published on : 11/8/2013
Exists online : False
Views : 341