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You cannot repair virtual disks after you reconnect the corresponding physical disks in a JBOD array in Windows Server 2012


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install a Just a Bunch of Disks (JBOD) array on a computer that is running Windows Server 2012.
  • You create a storage pool for all physical disks. Then, you use the physical disks to create virtual disks. 
  • You disconnect certain physical disks.
  • The virtual disks that correspond to the disconnected physical disks are in the Degraded state. 
  • You wait for 10 minutes.
  • You reconnect the disconnected physical disks, and the physical disks are recognized as healthy. However, the physical disks are in the Retired state.
  • You manually set the usage type of the physical disks to AutoSelect so that the physical disks are not in the Retired state.
  • You try to repair the virtual disks that correspond to the reconnected physical disks by using the Repair-VirtualDisk cmdlet.
In this scenario, the Repair-VirtualDisk cmdlet exits immediately, and no error message is returned. Therefore, the physical disks return to the Retired state, and the virtual disks remain in the Degraded state.

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Cause

This issue occurs because the columns for the physical disks that you disconnect are marked as FAILED. Therefore, Windows assigns the Retired status to the physical disks.

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Resolution

This hotfix is also available at Microsoft Update Catalog.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012.

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2012 file information notes
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.2.920 0.16 xxxWindows Server 2012RTMGDR
    6.2.920 0.20 xxxWindows Server 2012RTMLDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows RT, Windows 8, and Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Spaceport.sys6.2.9200.16704284,50431-Aug-201305:55x64
Spaceport.sys6.2.9200.20812284,50431-Aug-201307:01x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2012

Additional files for all supported x64-based versions of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Amd64_spaceport.inf_31bf3856ad364e35_6.2.9200.16704_none_6ef7ef77dffca3dd.manifestNot applicable2,12031-Aug-201306:01Not applicable
Amd64_spaceport.inf_31bf3856ad364e35_6.2.9200.20812_none_6f74bbc2f9242cea.manifestNot applicable2,12031-Aug-201307:07Not applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew

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Article Info
Article ID : 2885668
Revision : 1
Created on : 1/7/2017
Published on : 10/21/2013
Exists online : False
Views : 186