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Packet sniffing tool does not sniff all network traffic through port mirroring on a virtual machine that is hosted by a Windows Server 2012 Hyper-V server


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You create a virtual machine (VM) on a Windows Server 2012-based server that has the Hyper-V server role installed.
  • You connect the VM to a virtual switch that is connected to a physical network.
  • You have two computers (computer A and computer B) that both connect to the physical network.
  • The two computers and the VM are in the same subnet.
  • You set Mirroring Mode to Destination under the Port Mirroring section of Advanced Features in the VM's network settings.
  • You run a packet sniffing tool on the VM.
  • You ping computer B from computer A.
In this scenario, the packet sniffing tool does not capture the packets between computer B and computer A.

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Cause

This issue occurs because the virtual switch does not deliver the packets to the mirroring destination port.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012.

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You might need to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2012 file information notes
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.2.920 0.20 xxxWindows Server 2012RTMLDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Vmsif.dll6.2.9200.1638446,08026-Jul-123:07x64
Vmsntfy.dll6.2.9200.1638489,08826-Jul-123:07x64
Vmswitch.sys6.2.9200.20816566,7846-Sep-134:13x64
Vmsif.dll6.2.9200.1638446,08026-Jul-123:07x64
Vmsntfy.dll6.2.9200.1638489,08826-Jul-123:07x64
Vmswitch.sys6.2.9200.20816566,7846-Sep-134:13x64



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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2012
Additional files for all supported x64-based versions of Windows Server 2012
File propertyValue
File nameAmd64_91d0c30620f3d1334d6cf1f41cea21a8_31bf3856ad364e35_6.2.9200.20816_none_ee82b619ef9dcdb7.manifest
File versionNot applicable
File size708
Date (UTC)6-Sep-13
Time (UTC)15:53
PlatformNot applicable
File nameAmd64_microsoft-hyper-v-drivers-vmswitch_31bf3856ad364e35_6.2.9200.20816_none_c2ac355322c421e5.manifest
File versionNot applicable
File size162,594
Date (UTC)6-Sep-13
Time (UTC)15:53
PlatformNot applicable
File nameAmd64_wvms_pp.inf_31bf3856ad364e35_6.2.9200.20816_none_bc868f2d94099ad9.manifest
File versionNot applicable
File size3,379
Date (UTC)6-Sep-13
Time (UTC)15:53
PlatformNot applicable

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew, kb

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Article Info
Article ID : 2885541
Revision : 1
Created on : 1/7/2017
Published on : 10/11/2013
Exists online : False
Views : 161