Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

SMB 3.0 Transparent Failover feature does not work after you disconnect a drive cable in Windows Server 2012


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a multiple-node failover cluster that is running Windows Server 2012.
  • You create a cluster file share on the cluster.
  • You connect to the share from a Windows 8-based or Windows Server 2012-based client computer.
  • You transfer a file to or from the share.
  • During the file transfer, you disconnect the cable that connects the drive to the cluster.
  • You receive an error message that resembles the following on the client computer:
    STATUS_DEVICE_NOT_CONNECTED
In this scenario, the Server Message Block (SMB) 3.0 Transparent Failover feature does not work, and the file transfer fails.

Note The expected behavior is that the client computer reconnects to another cluster node to continue the file transfer after you disconnect the drive cable.

↑ Back to the top


Cause

This issue occurs because the SMB 3.0 driver does not handle the "STATUS_DEVICE_NOT_CONNECTED" error correctly.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.





Windows Server 2012 file information notes
Important Windows 8 hotfixes and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    VersionProductMilestoneService branch
    6.2.920 0.16 xxxWindows Server 2012RTMGDR
    6.2.920 0.20 xxxWindows Server 2012RTMLDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012
File propertyValue
File nameSrv2.sys
File version6.2.9200.16708
File size621,568
Date (UTC)06-Sep-2013
Time (UTC)03:17
Platformx64
File nameSrv2.sys
File version6.2.9200.20816
File size618,496
Date (UTC)06-Sep-2013
Time (UTC)04:15
Platformx64


↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about the SMB Transparent Failover feature, go to the following Microsoft website: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Additional file information

Additional file information for Windows Server 2012

Additional files for all supported x64-based versions of Windows Server 2012
File propertyValue
File nameAmd64_117d15b7dc02456d708f11e3e5c8f9d3_31bf3856ad364e35_6.2.9200.16708_none_1d1e097b63799a10.manifest
File versionNot applicable
File size704
Date (UTC)06-Sep-2013
Time (UTC)22:10
PlatformNot applicable
File nameAmd64_cc864020a95d8e69118ebd6c115c7e15_31bf3856ad364e35_6.2.9200.20816_none_e56191784216bfea.manifest
File versionNot applicable
File size704
Date (UTC)06-Sep-2013
Time (UTC)22:10
PlatformNot applicable
File nameAmd64_microsoft-windows-smbserver-v2_31bf3856ad364e35_6.2.9200.16708_none_3310c8f37ffb642d.manifest
File versionNot applicable
File size207,159
Date (UTC)06-Sep-2013
Time (UTC)07:50
PlatformNot applicable
File nameAmd64_microsoft-windows-smbserver-v2_31bf3856ad364e35_6.2.9200.20816_none_338d953e9922ed3a.manifest
File versionNot applicable
File size207,159
Date (UTC)06-Sep-2013
Time (UTC)06:57
PlatformNot applicable

↑ Back to the top


Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

↑ Back to the top

Article Info
Article ID : 2884665
Revision : 1
Created on : 1/7/2017
Published on : 10/11/2013
Exists online : False
Views : 240