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500 error when you try to access a Remote Desktop Web Access portal on a Windows Server 2008 R2 SP1-based computer


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You build a Remote Desktop Web Access portal on one or more Windows Server 2008 R2 Service Pack 1 (SP1)-based computers.
  • You log on the Remote Desktop Web Access portal.
  • You use a Remote Desktop application or desktop.
  • You restart one of the Remote Desktop session hosts that hosts the Remote Desktop applications or desktops.
  • After 2 or 3 hours, you try to access the Remote Desktop Web Access portal again.
In this scenario, error code 500 is generated. Additionally, you receive the following error message:

An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Also, the following event is logged in the Windows Event Log on the Remote Desktop Web Access server:

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Cause

This issue occurs because an exception is not handled correctly.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 Service Pack 1 (SP1). For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    1.17xxx
    Windows Server 2008 R2SP1GDR
    6.1.760
    1.22xxx
    Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Tsportalwebpart.dll6.1.7601.22435303,10428-Aug-201302:32x86
Tswf.xsdNot applicable6,41010-Jun-200920:41Not applicable
Web.configNot applicable1,30205-Nov-201001:57Not applicable
Webfeed.aspxNot applicable13110-Jun-200920:41Not applicable
Webfeed.aspx.csNot applicable1,30110-Jun-200920:41Not applicable
Allusers_tswa.logNot applicable19005-Nov-201001:57Not applicable
Aspnetdb.mdfNot applicable10,485,76005-Nov-201001:57Not applicable
Aspnetdb_log.ldfNot applicable516,09605-Nov-201001:57Not applicable
Banner_01.jpgNot applicable27,38505-Nov-201001:57Not applicable
Banner_02.jpgNot applicable14,23405-Nov-201001:57Not applicable
Bar_03.jpgNot applicable7,29505-Nov-201001:57Not applicable
Bg_globe_01.jpgNot applicable76,79305-Nov-201001:57Not applicable
Bottom_left.pngNot applicable25205-Nov-201001:57Not applicable
Bottom_mid.pngNot applicable22405-Nov-201001:57Not applicable
Bottom_right.pngNot applicable26405-Nov-201001:57Not applicable
Clear.gifNot applicable4305-Nov-201001:57Not applicable
Default.aspxNot applicable4,22205-Nov-201001:57Not applicable
Default.aspx.csNot applicable37805-Nov-201001:57Not applicable
Erroricon.pngNot applicable2,41405-Nov-201001:57Not applicable
Ivmo.pngNot applicable66805-Nov-201001:57Not applicable
Left_mid.pngNot applicable21105-Nov-201001:57Not applicable
Logo_01.pngNot applicable3,49205-Nov-201001:57Not applicable
Logo_02.pngNot applicable7,08405-Nov-201001:57Not applicable
Mslogo_black.pngNot applicable3,66405-Nov-201001:57Not applicable
Rapapplicationspart.xslNot applicable1,50705-Nov-201001:57Not applicable
Rapwait.gifNot applicable3,12405-Nov-201001:57Not applicable
Renderscripts.jsNot applicable16,97205-Nov-201001:57Not applicable
Right_mid.pngNot applicable21405-Nov-201001:57Not applicable
Top_left.pngNot applicable23405-Nov-201001:57Not applicable
Top_mid.pngNot applicable20605-Nov-201001:57Not applicable
Top_right.pngNot applicable27105-Nov-201001:57Not applicable
Tscpubstub.dll6.1.7601.1751422,52820-Nov-201013:27x64
Tsportalsetup.exe6.1.7601.2243587,55228-Aug-201301:44x64
Tsportalwebpart.dll6.1.7601.22435303,10428-Aug-201302:32x86
Tspubfilter.dll6.1.7601.1751412,28820-Nov-201013:27x64
Tswa_migplugin.dll6.1.7601.22435150,52828-Aug-201302:27x64
Tswebaccess.xmlNot applicable36205-Nov-201001:58Not applicable
Tswf.xsdNot applicable6,41005-Nov-201001:57Not applicable
Warning24.pngNot applicable1,22105-Nov-201001:57Not applicable
Web.configNot applicable4,95309-Jul-201305:56Not applicable
Webfeed.aspxNot applicable13105-Nov-201001:57Not applicable
Webfeed.aspx.csNot applicable1,75205-Nov-201001:57Not applicable
Ws_h_c.pngNot applicable3,42405-Nov-201001:57Not applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File propertyValue
File nameAmd64_be4b228327b856c836ce7cc92d73b89f_31bf3856ad364e35_6.1.7601.22435_none_ff20e8a76dfcc4f9.manifest
File versionNot applicable
File size689
Date (UTC)28-Aug-2013
Time (UTC)13:31
PlatformNot applicable
File nameAmd64_df6ae7668616ec7772595c31dee8d764_31bf3856ad364e35_6.1.7601.22435_none_1787aeea678efa24.manifest
File versionNot applicable
File size689
Date (UTC)28-Aug-2013
Time (UTC)13:31
PlatformNot applicable
File nameAmd64_tsportalwebfeed_31bf3856ad364e35_6.1.7601.22435_none_957465221de7d715.manifest
File versionNot applicable
File size8,181
Date (UTC)28-Aug-2013
Time (UTC)02:56
PlatformNot applicable
File nameAmd64_tsportalwebpart_31bf3856ad364e35_6.1.7601.22435_none_9330da3e1f67c5f0.manifest
File versionNot applicable
File size38,181
Date (UTC)28-Aug-2013
Time (UTC)13:31
PlatformNot applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix

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Article Info
Article ID : 2883489
Revision : 1
Created on : 1/7/2017
Published on : 10/9/2013
Exists online : False
Views : 212