Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Incorrect UI color rendering when an application uses the D3D11CreateDevice or D3D10CreateDevice function in Windows


View products that this article applies to.

Symptoms

Assume that you have a computer that is running Windows 8, Windows Server 2012, Windows 7 Service Pack 1 (SP1), or Windows Server 2008 R2 SP1. When you run an application that uses the D3D11CreateDevice function or the D3D10CreateDevice function, the user interface (UI) color of the application is rendered incorrectly.

↑ Back to the top


Cause

This issue occurs because D3D10.1 is incorrectly exposed on feature level 10.0.

↑ Back to the top


Resolution

Update information for Windows 8 and Windows Server 2012

To resolve this issue in Windows 8 or Windows Server 2012, install the update that is described in this article.

How to obtain this update

Windows Update
This update is available from Windows Update.
Microsoft Download Center
The following files are available for download from the Microsoft Download Center:
Operating systemUpdate
All supported x86-based versions of Windows 8Download Download the package now.
All supported x64-based versions of Windows 8Download Download the package now.
All supported x64-based versions of Windows Server 2012Download Download the package now.
For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Hotfix information for Windows 7 SP1 and Windows Server 2008 R2 SP1

To resolve this issue in Windows 7 SP1 or Windows Server 2008 R2 SP1, install the hotfix that is described in this article.


A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 SP1 or Windows Server 2008 R2 SP1.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760 1.18xxxWindows 7 and Windows Server 2008 R2SP1GDR
    6.1.760
    1.22xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
D3d11.dll6.2.9200.166991,505,28028-Aug-201323:05x86
D3d11.dll6.2.9200.208071,505,28028-Aug-201323:06x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
D3d11.dll6.2.9200.166991,887,23228-Aug-201322:44x64
D3d11.dll6.2.9200.208071,887,74428-Aug-201322:45x64
D3d11.dll6.2.9200.166991,505,28028-Aug-201323:05x86
D3d11.dll6.2.9200.208071,505,28028-Aug-201323:06x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about the D3D11CreateDevice function, go to the following Microsoft website:For more information about the D3D10CreateDevice function, go to the following Microsoft website:
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File propertyValue
File nameX86_798b6ead9a765974fa5608b9ebdcbde2_31bf3856ad364e35_7.1.7601.22436_none_c767739bbc057100.manifest
File versionNot applicable
File size706
Date (UTC)29-Aug-2013
Time (UTC)20:14
File nameX86_9e63c046dfdd027c8a31e530e24f2f2a_31bf3856ad364e35_7.1.7601.18247_none_a032ed7b0dc9f96d.manifest
File versionNot applicable
File size706
Date (UTC)29-Aug-2013
Time (UTC)20:14
File nameX86_microsoft-windows-directx-direct3d11_31bf3856ad364e35_7.1.7601.18247_none_e312a9a7b6ea9b40.manifest
File versionNot applicable
File size700,087
Date (UTC)29-Aug-2013
Time (UTC)02:37
File nameX86_microsoft-windows-directx-direct3d11_31bf3856ad364e35_7.1.7601.22436_none_e3a617fad00102e9.manifest
File versionNot applicable
File size700,087
Date (UTC)29-Aug-2013
Time (UTC)02:24
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File propertyValue
File nameAmd64_05ed140f16aeb2ff97c3fa54bcea3b1a_31bf3856ad364e35_7.1.7601.22436_none_0ed6add42ad3ee92.manifest
File versionNot applicable
File size1,060
Date (UTC)29-Aug-2013
Time (UTC)20:14
File nameAmd64_f9ea3e1d153e815afa2b8f89345ddf2c_31bf3856ad364e35_7.1.7601.18247_none_a980a764d2f3471b.manifest
File versionNot applicable
File size1,060
Date (UTC)29-Aug-2013
Time (UTC)20:14
File nameAmd64_microsoft-windows-directx-direct3d11_31bf3856ad364e35_7.1.7601.18247_none_3f31452b6f480c76.manifest
File versionNot applicable
File size700,089
Date (UTC)29-Aug-2013
Time (UTC)02:45
File nameAmd64_microsoft-windows-directx-direct3d11_31bf3856ad364e35_7.1.7601.22436_none_3fc4b37e885e741f.manifest
File versionNot applicable
File size700,089
Date (UTC)29-Aug-2013
Time (UTC)02:56
File nameX86_microsoft-windows-directx-direct3d11_31bf3856ad364e35_7.1.7601.18247_none_e312a9a7b6ea9b40.manifest
File versionNot applicable
File size700,087
Date (UTC)29-Aug-2013
Time (UTC)02:37
File nameX86_microsoft-windows-directx-direct3d11_31bf3856ad364e35_7.1.7601.22436_none_e3a617fad00102e9.manifest
File versionNot applicable
File size700,087
Date (UTC)29-Aug-2013
Time (UTC)02:24


↑ Back to the top


Keywords: kb, kbautohotfix, atdownload, kbhotfixserver, kbsurveynew, kbfix, kbqfe, kbexpertiseadvanced

↑ Back to the top

Article Info
Article ID : 2882780
Revision : 2
Created on : 4/9/2020
Published on : 4/9/2020
Exists online : False
Views : 242