Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

RPC Client Access service crashes when you use Outlook in ANSI online mode in an Exchange Server 2010 environment


View products that this article applies to.

Symptoms

Assume that your DisplayName property is blank in a Microsoft Exchange Server 2010 environment. Additionally, assume that Microsoft Outlook is running in ANSI online mode, and you have an online profile to receive email messages. In this situation, the Microsoft Exchange RPC Client Access service (Microsoft.Exchange.RpcClientAccess.Service.exe) crashes. Therefore, you cannot access your mailbox. Additionally, the following event is logged in the Application log on the Client Access server:

↑ Back to the top


Cause

This issue occurs because a System.ArgumentNullException exception occurs in the DoesEncodingUseFallbackCharacters function.

↑ Back to the top


Resolution

To resolve this issue, install the following update rollup:
2891587 Description of Update Rollup 3 for Exchange Server 2010 Service Pack 3

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about the RPC Client Access service, go to the following Microsoft website:

↑ Back to the top


Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseinter, kb

↑ Back to the top

Article Info
Article ID : 2880290
Revision : 1
Created on : 1/7/2017
Published on : 11/25/2013
Exists online : False
Views : 304