Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Drive is unexpectedly mapped to the root of a nested share in Windows


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows 8.1, Windows Server 2012 R2, Windows 8 or Windows Server 2012.
  • You configure the value of the EnableLinkedConnections registry entry to 1 to enable elevated processes to access network shares.
  • You try to map a drive to a nested share by using an elevated token on the computer. For example, you try to map a drive to the following share path:
    \\computername\share\myshare\user
In this scenario, the drive is unexpectedly mapped to the root of the nested share. For example, the drive is unexpectedly mapped to the following path:
\\computername\share

↑ Back to the top


Cause

This issue occurs because the code that is used to create the symbolic link does not append the prefixed name of the target to the name of the linked target during the link target name construction process.

↑ Back to the top


Resolution

Windows 8.1 and Windows Server 2012 R2 update information

To resolve this issue in Windows 8.1 and Windows Server 2012 R2, install update rollup 2919394. For more information about how to obtain this update rollup package, click the following article number to go to the article in the Microsoft Knowledge Base:
2919394 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 update rollup: February 2014

Windows 8 and Windows Server 2012 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 8.1, Windows Server 2012 R2, Windows 8 or Windows Server 2012.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.





Windows 8 and Windows Server 2012 file information notes
Important Windows 8 hotfixes and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    VersionProductMilestoneService branch
    6.2.920 0.20 xxxWindows 8 and Windows Server 2012RTMLDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 8 and Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 8
File propertyValue
File nameRdbss.sys
File version6.2.9200.20793
File size321,024
Date (UTC)09-Aug-2013
Time (UTC)04:01
Platformx86
For all supported x64-based versions of Windows 8 and of Windows Server 2012
File propertyValue
File nameRdbss.sys
File version6.2.9200.20793
File size423,936
Date (UTC)09-Aug-2013
Time (UTC)06:56
Platformx64


↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Additional file information

Additional file information for Windows 8 and Windows Server 2012

Additional files for all supported x86-based versions of Windows 8
File propertyValue
File nameX86_85408ac086f1f0fa7bc00c641875d53a_31bf3856ad364e35_6.2.9200.20793_none_153084fb133b7ba1.manifest
File versionNot applicable
File size693
Date (UTC)09-Aug-2013
Time (UTC)14:51
PlatformNot applicable
File nameX86_microsoft-windows-rdbss_31bf3856ad364e35_6.2.9200.20793_none_56fdb5f44bf6ce2e.manifest
File versionNot applicable
File size22,921
Date (UTC)09-Aug-2013
Time (UTC)05:50
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 8 and of Windows Server 2012
File propertyValue
File nameAmd64_a4f81aaf37f2a43dc8f32261a5caafa2_31bf3856ad364e35_6.2.9200.20793_none_ee8273989dfd6874.manifest
File versionNot applicable
File size697
Date (UTC)09-Aug-2013
Time (UTC)15:24
PlatformNot applicable
File nameAmd64_microsoft-windows-rdbss_31bf3856ad364e35_6.2.9200.20793_none_b31c517804543f64.manifest
File versionNot applicable
File size22,927
Date (UTC)09-Aug-2013
Time (UTC)09:09
PlatformNot applicable

↑ Back to the top


Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

↑ Back to the top

Article Info
Article ID : 2878604
Revision : 1
Created on : 1/7/2017
Published on : 2/13/2014
Exists online : False
Views : 284