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FIX: A "c000021a" error occurs when you restart a Windows Embedded POSReady 2009 device


View products that this article applies to.

Symptoms

When you restart a Windows Embedded POSReady 2009 device, you receive a "c000021a" error message.

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Cause

This problem occurs because of a race condition and a NULL pointer access that exist in the Winlogon process.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running a Windows Embedded POSReady 2009 device. 



Restart requirement

You must restart the device after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows XP file information notes

  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows XP
File nameFile versionFile sizeDateTimePlatform
Licdll.dll5.1.2600.6436423,9368-Aug-135:13x86
Winlogon.exe5.1.2600.6436509,4408-Aug-133:24x86
Dpcdll.dll5.1.2600.6436104,9608-Aug-133:22x86
Dpcdll.dll5.1.2600.6436104,4488-Aug-135:13x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbbug, kb

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Article Info
Article ID : 2878379
Revision : 1
Created on : 1/7/2017
Published on : 10/9/2013
Exists online : False
Views : 213