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FIX: "SODA File Server Clone failed. Error=0x80070057" error when a failover of the virtual machines starts on a Windows Server 2012-based Hyper-V failover cluster


View products that this article applies to.

Symptoms

Assume that you deploy a Windows Server 2012-based Hyper-V failover cluster that is based on a Scale-Out File Server cluster. When a failover of the virtual machines starts, the Vmms.exe process tries to access the file share or to unregister the virtual machines. In this situation, the Vmms.exe process stops responding. Moreover, virtual machines are left in a running-critical state on one or multiple Hyper-V host nodes and are unusable.

Additionally, the following event is logged in the System log:

Log Name: System
Source: Microsoft-Windows-FailoverClustering
Date: date
Event ID: 1603
Task Category: File Server Resource
Level: Error
Keywords:
User: SYSTEM
Computer: computer_name
Description:
SODA File Server Clone failed. Error=0x80070057.

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Cause

This problem occurs when a Scale-Out File Server clone resource tries to add Server Message Block (SMB) shares before the Distributed Network Name clone resource has added the network name to the SMB server name list. This causes the SMB shares not to be created as expected.

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Resolution

This hotfix is also available at Microsoft Update Catalog.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012.



Restart requirement

You may have to restart the computer after you apply this hotfix. 

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2012 file information notes

Important Windows 8 and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    VersionProductMilestoneService branch
    6.2.920 0.20 xxxWindows Server 2012RTMLDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Clusres.dll6.2.9200.207922,463,74408-Aug-201305:54x64
Clussvc.exe6.2.9200.207927,228,92808-Aug-201305:58x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Additional file information

Additional file information for Windows Server 2012

Additional files for all supported x64-based versions of Windows Server 2012
File nameAmd64_a22f57a405d948774dab326a06cc13c2_31bf3856ad364e35_6.2.9200.20792_none_91cbe4c7cf92c22a.manifest
File versionNot applicable
File size715
Date (UTC)08-Aug-2013
Time (UTC)22:52
PlatformNot applicable
File nameAmd64_b7e9205354997eeaa271615697f145a1_31bf3856ad364e35_6.2.9200.20792_none_b0fd7ae3f7d310a3.manifest
File versionNot applicable
File size1,072
Date (UTC)08-Aug-2013
Time (UTC)22:52
PlatformNot applicable
File nameAmd64_microsoft-windows-f..overcluster-clusres_31bf3856ad364e35_6.2.9200.20792_none_1a21188d3fe6ff81.manifest
File versionNot applicable
File size2,732
Date (UTC)08-Aug-2013
Time (UTC)08:56
PlatformNot applicable
File nameAmd64_microsoft-windows-f..overcluster-clussvc_31bf3856ad364e35_6.2.9200.20792_none_130822af44778419.manifest
File versionNot applicable
File size10,086
Date (UTC)08-Aug-2013
Time (UTC)08:57
PlatformNot applicable
File nameWow64_microsoft-windows-f..overcluster-clussvc_31bf3856ad364e35_6.2.9200.20792_none_1d5ccd0178d84614.manifest
File versionNot applicable
File size6,868
Date (UTC)08-Aug-2013
Time (UTC)07:34
PlatformNot applicable

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbbug, kb

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Article Info
Article ID : 2878224
Revision : 1
Created on : 1/7/2017
Published on : 9/11/2013
Exists online : False
Views : 221