Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Performance Degradation Experience in Microsoft Dynamics CRM Due To High Number of Temporary Files


View products that this article applies to.

Symptoms

You may experience a degradation in performance, which can arise either because the SDK solution is running out of available file names or because an antivirus program is performing scans when files are created.

↑ Back to the top


Cause

There is a limit of 65,335 files that can be created in the Windows temporary directory and when that limit is reached, processes that need to create these files are unable to do so which either impacts performance or makes the application unresponsive.

↑ Back to the top


Resolution

A best practice for the temporary directory is to have it cleared on the server on a regular basis as part of a normal maintenance routine. There are a number of tools and utilities out there that can do automated cleanup.

↑ Back to the top


Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 2877070
Revision : 1
Created on : 1/7/2017
Published on : 9/6/2013
Exists online : False
Views : 169