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XADM: Non-Delivery Report: Unable to Forward the Message Because No Directory Server Was Available


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This article was previously published under Q287423

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Symptoms

In a mixed Exchange Server 5.5-Exchange 2000 site in which an Exchange Server 5.5 computer is listed in the Domain Name Server (DNS) as the default mail exchanger, the Exchange Server 5.5 message transfer agent (MTA) may return an incoming Simple Mail Transfer Protocol (SMTP) message with a non-delivery report (NDR) that contains the following information:
Unable to forward the message because no directory server was available. Please try again later or contact your system administrator. The MTS-ID of the original message is: <MsgID> MSEXCH:MSExchangeMTA:<Site>:<Server>
Alternatively, the following NDR may be returned:
Your message <Sender and recipient information> did not reach the following recipient(s): <Recipient> on <Date & Time> A required directory operation was unsuccessful The MTS-ID of the original message is: <MsgID> MSEXCH:MSExchangeMTA:<Site>:<Server>

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Cause

This behavior can occur after an incomplete Active Directory Connector (ADC) replication with the Site Replication Service (SRS). The Exchange Server 5.5 computer has mailbox information for the Exchange 2000 mailboxes, but not server information. Therefore, when the incoming SMTP message is routed to the Exchange Server 5.5 MTA, the MTA knows what server should receive this message but cannot find a route or directory server for the destination (Exchange 2000) server.

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Resolution

To resolve this problem, follow the steps in the following Microsoft Knowledge Base article to rebuild SRS.
282061� XADM: How to Rebuild a Site Replication Service Without a Backup

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Workaround

To work around this problem for incoming SMTP messages, change the DNS MX record to indicate only the Exchange 2000 server.

If you no longer need the Exchange Server 5.5 computer, another workaround is to move all mailboxes to the Exchange 2000 server, recreate any connectors that the Exchange Server 5.5 computer hosts on the Exchange 2000 server, and then remove the Exchange Server 5.5 computer.

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More information

The problem is that the Exchange 2000 server's information is not created (or simply does not exist) in the SRS database, but the user information does exist in the SRS. Therefore, the Exchange Server 5.5 MTA knows about the Exchange 2000 users but not about the servers where those users' mailboxes are located. Unfortunately, completing the synchronization the servers between is not possible.

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Keywords: KB287423, kbprb

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Article Info
Article ID : 287423
Revision : 6
Created on : 2/27/2007
Published on : 2/27/2007
Exists online : False
Views : 304