Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: The SnaBase process may stop when a user tries to connect to a server that is running Host Integration Server 2009


View products that this article applies to.

Symptoms

When a user tries to connect to a server that is running Microsoft Host Integration Server 2009, the SnaBase process may stop unexpectedly.

↑ Back to the top


Cause

This issue occurs because an access violation occurs while the server is checking whether encryption is enabled for the user who is trying to connect. Specifically, the access violation occurs when the Snadmod.dll file tries to free an internal control memory block that was freed previously. The second try to free this memory block causes an access violation that results in the abnormal termination of the SnaBase process.

↑ Back to the top


Resolution

Cumulative update information

Microsoft Host Integration Server 2009
The fix that resolves this problem is included in Cumulative Update 6 for Host Integration Server 2009.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Cumulative Update 5 for Host Integration Server 2009 installed to apply this hotfix.

Restart information

You may have to restart the computer after you apply this hotfix.

Replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Microsoft Host Integration Server 2009, 32-bit Edition
File nameFile versionFile sizeDateTimePlatform
Snadmod.dll8.0.4081.2815,25601-Aug-201300:18x86
Microsoft Host Integration Server 2009, 64-bit Edition
File nameFile versionFile sizeDateTimePlatform
Snadmod.dll8.0.4081.2815,25601-Aug-201300:18x86
Snadmod.dll8.0.4081.21,022,61601-Aug-201300:22x64
Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

If you capture a dump file of the access violation when this problem occurs, the dump file includes a stack trace that resembles the following:

snadmod!GetUserEncryptionFlag_cb+0x95a
snadmod!LocalProcessRpc+0xaeb
snadmod!DMODReleaseLtab+0x923
kernel32!BaseThreadInitThunk+0xe
ntdll!__RtlUserThreadStart+0x23
ntdll!_RtlUserThreadStart+0x1b

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbbug, kb

↑ Back to the top

Article Info
Article ID : 2873486
Revision : 1
Created on : 1/7/2017
Published on : 12/2/2013
Exists online : False
Views : 341