Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The size of the "HKEY_USERS\.DEFAULT" registry hive continuously increases on a Windows Server-based server


View products that this article applies to.

Symptoms

Assume that you have a server that is running Windows Server 2012 R2 or Windows Server 2008 R2 Service Pack 1 (SP1). Many users connect to the server by using a certain remote desktop application. In this situation, the size of the following registry hive may exceed the limit:
HKEY_USERS\.DEFAULT
Therefore, the users cannot connect to the server.

↑ Back to the top


Cause

This issue occurs because of an error that occurs in the Print Spooler modules. When a user establishes a new remote desktop session to the server, the printer settings of the user are written in the following registry subkey:
HKEY_USERS\.DEFAULT\Printers\DevModes2
However, the printer settings are never deleted. Therefore, the size of the following registry hive becomes larger and larger, and various problems are caused by this behavior:
HKEY_USERS\.DEFAULT

↑ Back to the top


Resolution

Update Rollup for Windows Server 2012 R2

To resolve this issue in Windows Server 2012 R2, install update 2955164. For more information about update 2955164, click the following article number to view the article in the Microsoft Knowledge Base:
2955164 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 update rollup: May 2014
To resolve this issue in Windows Server 2008 R2, install the hotfix that is described in this article.

Hotfix information for Windows Server 2008 R2

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Compress the registry hive

After you install this update, we recommend that you compress the following registry hive if its size exceed the limit:HKEY_USERS\.DEFAULTTo compress the registry hive, follow the steps in the following Microsoft knowledge base article:Note When you follow these steps to compress HKEY_USERS\.DEFAULT, the hive file can be located in C:\windows\system32\config\DEFAULT.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 SP1.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    1.22xxx
    Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Winspool.drv6.1.7601.22406442,88030-Jul-201302:23Not applicable
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Winspool.drv6.1.7601.22406863,23230-Jul-201301:40Not applicable

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File propertyValue
File nameAmd64_microsoft-windows-p..ting-spooler-client_31bf3856ad364e35_6.1.7601.22406_none_f1ea4e45486130a1.manifest
File versionNot applicable
File size2,774
Date (UTC)30-Jul-2013
Time (UTC)02:48
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File propertyValue
File nameIa64_microsoft-windows-p..ting-spooler-client_31bf3856ad364e35_6.1.7601.22406_none_95cd56b79001c867.manifest
File versionNot applicable
File size2,772
Date (UTC)30-Jul-2013
Time (UTC)02:14
PlatformNot applicable

↑ Back to the top


Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

↑ Back to the top

Article Info
Article ID : 2871131
Revision : 1
Created on : 1/7/2017
Published on : 2/26/2015
Exists online : False
Views : 457