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I/O failures occur when you create a snapshot for a large volume in Windows Server 2012 or Windows Server 2008 R2 SP1


View products that this article applies to.

Symptoms

When you create a snapshot for a large volume on a Windows Server 2012-based or Windows Server 2008 R2 Service Pack 1 (SP1)-based computer, snapshot creation takes a long time to finish. Additionally, some I/O failures occur during snapshot creation.

For example, when you create a snapshot for a volume that is larger than 50 terabytes (TB), it takes a long time to complete the snapshot creation. Additionally, you experience mouse or keyboard input problems and network connection loss during the snapshot creation.

Note If this issue occurs on a Windows Server 2012-based failover cluster, cluster heartbeat failure occurs. Therefore, the cluster disk resource goes offline, and then the snapshot creation fails.

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Cause

This issue occurs because the Volsnap.sys driver spends too much time marking available space on the volume when holding a spinlock.

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Resolution

This hotfix is also available at Microsoft Update Catalog.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012 or Windows Server 2008 R2 SP1.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    1.18xxx
    Windows Server 2008 R2SP1GDR
    6.1.760 1.22xxxWindows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Volsnap.sys6.1.7601.18226296,38431-Jul-201302:35x64
Volsnap.sys6.1.7601.22407296,89631-Jul-201302:33x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Volsnap.sys6.1.7601.18226679,36031-Jul-201301:43IA-64
Volsnap.sys6.1.7601.22407681,40831-Jul-201301:37IA-64
Windows Server 2012 file information notes
Important Windows 8 hotfixes and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    VersionProductMilestoneService branch
    6.2.920 0.16 xxxWindows Server 2012RTMGDR
    6.2.920 0.20 xxxWindows Server 2012RTMLDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Volsnap.sys6.2.9200.16678328,02431-Jul-201303:11x64
Volsnap.sys6.2.9200.20786332,12031-Jul-201316:29x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File propertyValue
File nameAmd64_volume.inf_31bf3856ad364e35_6.1.7601.18226_none_73d3d11e12baf5d9.manifest
File versionNot applicable
File size2,087
Date (UTC)31-Jul-2013
Time (UTC)02:54
PlatformNot applicable
File nameAmd64_volume.inf_31bf3856ad364e35_6.1.7601.22407_none_74740ff12bc7743f.manifest
File versionNot applicable
File size2,087
Date (UTC)31-Jul-2013
Time (UTC)02:55
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File propertyValue
File nameIa64_volume.inf_31bf3856ad364e35_6.1.7601.18226_none_17b6d9905a5b8d9f.manifest
File versionNot applicable
File size2,085
Date (UTC)31-Jul-2013
Time (UTC)02:17
PlatformNot applicable
File nameIa64_volume.inf_31bf3856ad364e35_6.1.7601.22407_none_1857186373680c05.manifest
File versionNot applicable
File size2,085
Date (UTC)31-Jul-2013
Time (UTC)02:13
PlatformNot applicable

Additional file information for Windows Server 2012

Additional files for all supported x64-based versions of Windows Server 2012
File propertyValue
File nameAmd64_volume.inf_31bf3856ad364e35_6.2.9200.16678_none_6e8f35ab85cd71a4.manifest
File versionNot applicable
File size2,104
Date (UTC)31-Jul-2013
Time (UTC)03:15
PlatformNot applicable
File nameAmd64_volume.inf_31bf3856ad364e35_6.2.9200.20786_none_6f0c01f69ef4fab1.manifest
File versionNot applicable
File size2,104
Date (UTC)31-Jul-2013
Time (UTC)19:46
PlatformNot applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

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Article Info
Article ID : 2871085
Revision : 1
Created on : 1/7/2017
Published on : 9/11/2013
Exists online : False
Views : 285