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Business Desk Fails to Load with Unspecified Error (0x80004005)


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This article was previously published under Q286388

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Symptoms

When you start Business Desk, the following error message occurs:
Error Type: (0x80004005) Unspecified error /BizDesk/navtree.asp, line 59

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Cause

This error occurs when Access Control Lists (ACLs) in the Business Desk files contain a domain global group.

Business Desk uses the Win32 API GetEffectiveRightsFromAcl to determine if a user has access to Business Desk. GetEffectiveRightsFromAcl returns an error when you use global domain groups.

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Resolution

To resolve this problem, apply the fix that is described in the following Knowledge Base article:
286360� GetEffectiveRightsFromAcl() Function Causes 'ERROR_NO_SUCH_DOMAIN' Error Message

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Workaround

Do not use global groups to assign permissions to the Business Desk module files.

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Status

Microsoft has confirmed that this is a problem in Microsoft Commerce Server 2000.

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Keywords: KB286388, kbpending, kbbug

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Article Info
Article ID : 286388
Revision : 1
Created on : 10/18/2002
Published on : 10/18/2002
Exists online : False
Views : 419