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Virtual machine backup fails in a Windows Server 2012 VDI deployment that enables user profile disks


View products that this article applies to.

Symptoms

Backup of virtual machines fails in a Windows Server 2012 Virtualization Desktop Infrastructure (VDI) deployment when the following conditions are true:
  • User profile disks are configured in the deployment.
  • One or more users are logged on during the backup.
In this scenario, the following event is logged in the Hyper-V-VMMS log:

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Cause

The issue occurs because user profile disks are included in system state metadata incorrectly.

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Resolution

After you apply the hotfix and restart the Hyper-V host, you must install Integration Services on the virtual machines. Otherwise, virtual machine backup may stop working. To install Integration Services on the virtual machines, follow these steps:
  1. In Hyper-V Manager, right-click one virtual machine, and then click Connect.
  2. Log on to the virtual machine as a local administrator.
  3. In the Virtual Machine Connection window, on the Action menu, then click Insert Integration Services Setup Disk.
  4. In the AutoPlay dialog box, select Install Hyper-V Integration Services, and then press Enter.
  5. In the Upgrade Hyper-V Integration Services dialog box, click OK.
  6. When you are prompted that the installation is complete, click Yes to restart the virtual machine.
  7. Repeat step 1 to step 6 to install Integration Services on all virtual machines.

Hotfix information

This hotfix is also available at Microsoft Update Catalog.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012.

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2012 file information notes
Important Windows 8 and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.2.920 0.20 xxxWindows Server 2012RTMLDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Setup.exe6.2.9200.20784226,60828-Jul-201305:48x64
Icsvc.dll6.2.9200.20784336,38428-Jul-201301:51x64
Vmictimeprovider.dll6.2.9200.2078459,90428-Jul-201302:41x64
Vmms.exe6.2.9200.2078411,201,53628-Jul-201301:17x64
Setup.exe6.2.9200.20784209,20028-Jul-201303:41x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Additional file information

Additional file information for Windows Server 2012

Additional files for all supported x64-based versions of Windows Server 2012
File nameAmd64_microsoft-hyper-v-g..aller-win5x-package_31bf3856ad364e35_6.2.9200.20784_none_2b8073c82d35f3a2.manifest
File versionNot Applicable
File size3,165
Date (UTC)28-Jul-2013
Time (UTC)06:05
PlatformNot Applicable
File nameAmd64_microsoft-hyper-v-g..aller-win6x-package_31bf3856ad364e35_6.2.9200.20784_none_2db6ddda6b8d2713.manifest
File versionNot Applicable
File size4,261
Date (UTC)28-Jul-2013
Time (UTC)06:19
PlatformNot Applicable
File nameAmd64_microsoft-hyper-v-guest-installer_31bf3856ad364e35_6.2.9200.20784_none_caf84b10c4a4c527.manifest
File versionNot Applicable
File size4,165
Date (UTC)28-Jul-2013
Time (UTC)06:06
PlatformNot Applicable
File nameAmd64_microsoft-hyper-v-integration-services_31bf3856ad364e35_6.2.9200.20784_none_fb18dc5593614963.manifest
File versionNot Applicable
File size28,185
Date (UTC)30-Jul-2013
Time (UTC)04:40
PlatformNot Applicable
File nameAmd64_microsoft-hyper-v-vstack-vmms_31bf3856ad364e35_6.2.9200.20784_none_8fe9518201ce82f2.manifest
File versionNot Applicable
File size1,135,762
Date (UTC)30-Jul-2013
Time (UTC)04:40
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size26,416
Date (UTC)30-Jul-2013
Time (UTC)04:40
PlatformNot Applicable
File nameX86_microsoft-hyper-v-g..aller-win5x-package_31bf3856ad364e35_6.2.9200.20784_none_cf61d84474d8826c.manifest
File versionNot Applicable
File size3,159
Date (UTC)28-Jul-2013
Time (UTC)04:07
PlatformNot Applicable
File nameX86_microsoft-hyper-v-g..aller-win6x-package_31bf3856ad364e35_6.2.9200.20784_none_d1984256b32fb5dd.manifest
File versionNot Applicable
File size4,253
Date (UTC)28-Jul-2013
Time (UTC)04:20
PlatformNot Applicable
File nameX86_microsoft-hyper-v-guest-installer_31bf3856ad364e35_6.2.9200.20784_none_6ed9af8d0c4753f1.manifest
File versionNot Applicable
File size3,222
Date (UTC)28-Jul-2013
Time (UTC)04:02
PlatformNot Applicable

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew, kb

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Article Info
Article ID : 2861935
Revision : 1
Created on : 1/7/2017
Published on : 9/11/2013
Exists online : False
Views : 188