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Event ID: 1002 occurs when you try to start the Microsoft Exchange directory service in Exchange Server 5.5


View products that this article applies to.

Symptoms

When you try to start the Microsoft Exchange directory service in Microsoft Exchange Server 5.5, you may receive an internal processing error. The following events are logged in the Application log:

Event ID: 1002
Source: MSExchangeDS
Type: Error
Category: Internal Processing
Description:
The Microsoft Exchange Server database, EDB, could not be initialized and returned error -1022.
Unrecoverable error. The directory cannot continue.


Event ID: 1002
Source: MSExchangeDS
Type: Error
Category: Internal Processing
Description:
The Microsoft Exchange Server database, EDB, could not be initialized and returned error -1811.
Unrecoverable error. The directory cannot continue.

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Cause

This problem occurs when one of the following conditions is true:
  • The Dir.edb database file is missing.
  • The registry entries that define the paths to the directory database and to other required files point to the incorrect locations.

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Resolution

To resolve this problem, verify that the Dir.edb database file file exists and verify the location of the file. Then, change the registry entries to point to the correct locations. To do this, follow these steps.

Verify the Dir.edb database file

  1. Search the hard drives on the computer for the Dir.edb database file.
  2. If the Dir.edb database file does not exist, restore the database from a backup.

    For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
    184186 Recovering Exchange from a corrupted directory
    177635 How to set up a disaster recovery server for Dir.edb
    183266 How to restore an offline backup of the directory service and information store

Verify the registry entries

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
  1. Start Registry Editor.
  2. Locate the following registry key:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDS\Parameters
  3. Verify that the following registry entries point to the correct locations. If a registry entry points to the wrong location, type the correct path for that entry:
    • Verify that the "DSA Database File" registry entry points to the Dir.edb database file.
    • Verify that the "Database log files path" registry entry points to the Edb.log files for the directory service.
    • Verify that the "DSA Working Directory" registry entry points to the Ebd.chk file for the directory service.
    Note For example, type Drive:\exchsrvr\dsadata.
  4. After you verify all the registry entries, start the directory service.

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Properties

Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

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Keywords: KB285675, kbprb, kbexchdirectory

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Article Info
Article ID : 285675
Revision : 2
Created on : 10/28/2006
Published on : 10/28/2006
Exists online : False
Views : 343