Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You may experience logon delays on a Windows Server 2008 R2-based Session Host server when mapping a large number of printers


Symptoms

In Windows, significant logon delays may occur when clients log on.  This problem occurs if most or all of the following conditions are true:

  • Multiple clients are simultaneously logging on to a Windows Server 2008 R2 Session Host Server or a Citrix XEN App Server
  • The clients are mapping a large number of printers via a script or Group Policy

↑ Back to the top


Cause

With the new Client Side Rendering change, the AddPrinterConnection command now installs a local version of the network printer.  The process includes downloading and installing the driver package from the Print Server, which can cause a spike in CPU usage by the spooler process.  In a Remote Desktop Session Host server environment, this can cause some performance issues on the Session Host server when users are configured to run a script that uses the AddPrinterConnection command to map the user's printers.  The Group Policy option to push printer connections for the user also exhibits this behavior.

↑ Back to the top


Resolution

Adding the DriverPolicy registry key on the Print Server instructs the client, in this case the Session Host Server, to use a locally installed driver rather than downloading it from the Print server.  This bypasses the driver download process that spikes the CPU.  If the client doesn't have the driver installed locally, it will still download it from the Print server as before, and you would see the CPU spike.  Once the print driver has been downloaded and installed, subsequent printer mappings using that driver will bypass downloading the driver, and the local driver will be used.

↑ Back to the top


More Information

NOTE:  If the Print Driver is updated on the Print Server and the name is the same as the old driver, the update will not be downloaded to the client.  In that case, the driver on the Session Host server would need to be deleted so that the new driver can be downloaded.

To have us fix this problem for you, go to the "Fix it for me" section. If you prefer to do this yourself, go to the "Let me fix it myself" section.

Fix it for me

To fix this problem automatically, click the Fix this problem link. Then click Run in the File Download dialog box, and follow the steps in this wizard.

Fix this problem
Microsoft Fix it 50998



Note This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.

Note If you are not on the computer that has the problem, you can save the automatic fix to a flash drive or to a CD so that you can run it on the computer that has the problem.

Note We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me" blog or send us an email message.

Let me fix it myself

See section "Client Side rendering with a driver mismatch" section in the following article:

http://msdn.microsoft.com/en-us/library/windows/hardware/ff556443(v=vs.85).aspx

↑ Back to the top


Keywords: vkball, kb

↑ Back to the top

Article Info
Article ID : 2853367
Revision : 1
Created on : 1/8/2017
Published on : 7/10/2013
Exists online : False
Views : 181