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FIX: A WFC channel for WebSphere MQ cannot reconnect in a Host Integration Server 2010 environment


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Symptoms

Consider the following scenario. You work with a Windows Communication Foundation (WCF) channel for WebSphere MQ in a Microsoft Host Integration Server 2010 environment. The queue manager is stopped for some reason, such as a connection reset in the transport.

In this scenario, the WCF channel cannot reconnect. Then, each successive read request fails, and you receive reason code 6124 as follows:

A method failed because a required connection to a queue manager was not available, and a connection cannot be established implicitly because the IMQ_IMPL_CONN flag of the ImqQueueManagerbehavior class attribute is FALSE.

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Cause

This problem occurs because the error is handled incorrectly when the queue manager is stopped.

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Resolution

Cumulative update information

The fix that resolves this problem is included in cumulative update package 8 for Host Integration Server 2010. For more information about how to obtain the cumulative update package, see Cumulative update package 8 for Host Integration Server 2010 .

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbqfe, kbfix, kbnotautohotfix, kbexpertiseinter, kbbug, kbsurveynew, kb

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Article Info
Article ID : 2849394
Revision : 1
Created on : 1/7/2017
Published on : 9/4/2013
Exists online : False
Views : 180