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MemberName attribute and Account Name field are not populated in a Windows Server 2008 R2-based domain


View products that this article applies to.

Symptoms

When you remove a member of a Global or Universal security group on a Windows Server 2008 R2-based domain controller, the MemberName attribute and the Account Name field are not populated in the security audit events. This problem occurs when you take any of the following actions:
  • You remove the member by using the user's security identifier (SID).
  • You remove the member from a group by using the Active Directory Administrative Center.
  • You remove the member by using the Remove-AdPrincipalGroupMembership Windows PowerShell cmdlet.

For example, you start the Active Directory Module for Windows PowerShell. To remove the user account "Audit1" in the Group1 Global security group, you use one of the following commands together with either the user's SID or the user's name:

PowerShell command using the users SID

PowerShell command using the users name

In this scenario, when you use either command, the MemberName attribute is not populated and is instead displayed as a dash (-) on the Details tab of the Event 4729 log. Additionally, the Account Name field is not populated and is instead displayed as a dash (-) on the General tab. The results are shown in the following screen shots.

The MemberName attribute is not populated and is displayed as a dash (-).

The Account Name field is not populated and is displayed as a dash (-).

Notes
  • This problem does not occur with the Domain Local group. The event always shows the MemberName attribute as the distinguished name, even if the removal is performed by using the member SID.
  • This problem can also occur in the Event ID 4757 log for the Universal group.

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Cause

This problem occurs because the Windows PowerShell command uses the user's SID when the request is sent by using the Lightweight Directory Access Protocol (LDAP) regardless of whether the identity is passed as a distinguished name.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 Service Pack 1 (SP1) .

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    VersionProductSR_LevelService branch
    6.1.760
    1.
    22xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Samsrv.dll6.1.7601.22313773,63201-May-201305:17x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Samsrv.dll6.1.7601.223131,431,04001-May-201304:23IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_microsoft-windows-directory-services-sam_31bf3856ad364e35_6.1.7601.22313_none_109cded3d0b2c144.manifest
File versionNot applicable
File size101,702
Date (UTC)01-May-2013
Time (UTC)21:22
PlatformNot applicable
File nameWow64_microsoft-windows-directory-services-sam_31bf3856ad364e35_6.1.7601.22313_none_1af189260513833f.manifest
File versionNot applicable
File size83,443
Date (UTC)01-May-2013
Time (UTC)05:14
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_microsoft-windows-directory-services-sam_31bf3856ad364e35_6.1.7601.22313_none_b47fe7461853590a.manifest
File versionNot applicable
File size101,698
Date (UTC)01-May-2013
Time (UTC)21:16
PlatformNot applicable
File nameWow64_microsoft-windows-directory-services-sam_31bf3856ad364e35_6.1.7601.22313_none_1af189260513833f.manifest
File versionNot applicable
File size83,443
Date (UTC)01-May-2013
Time (UTC)05:14
PlatformNot applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbbug

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Article Info
Article ID : 2844009
Revision : 1
Created on : 1/7/2017
Published on : 6/13/2013
Exists online : False
Views : 176