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You cannot log on to a client computer that has a cached locked out account in a Windows Server 2008 R2-based Active Directory domain environment


View products that this article applies to.

Symptoms

Assume that you have a client computer that has a cached locked-out account in a Windows Server 2008 R2-based Active Directory Domain Services (AD DS)environment. When you try to log on to the computer by using a smart card, the behavior differs from the behavior that occurs if you log on by using your username and password.

Consider the following scenarios.

Scenario 1
  • You use a smart card to log on to the cached locked-out account. The logon fails, and you receive the following error message:

    The system could not log you on. Your account has been disabled. Please see your system administrator.

  • You disconnect the computer from the AD DS environment, and then you try to log on again.
In this scenario, the logon fails, and you receive the following error message:

The system could not log you on. The domain specified is not available. Please try again later.


Scenario 2
  • You use your username and password to log on to the cached locked-out account. The logon fails, and you receive the following error message:

    The reference account is currently locked out and may not be logged on to.
  • You disconnect the computer from the AD DS environment.
In this scenario, the logon succeeds by using your cached credentials.

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Cause

This problem occurs because the Key Distribution Center (KDC) sends a KDC_ERR_CLIENT_REVOKED error only when you use your smart card to log on to the locked-out user account. This error message is mapped back to the STATUS_ACCOUNT_DISABLED value. This causes the cached account to be reported as disabled on the computer. The related cached credentials are then deleted.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 Service Pack 1 (SP1). For information about how to obtain a Windows Server 2008 R2 service pack, see Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2 .

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies to" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    VersionProductSR_LevelService branch
    6.1.760
    1.
    22xxx
    Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Kdcsvc.dll6.1.7601.22313435,20001-May-201305:17x64
Kdcsvc.mofNot Applicable5,30005-Nov-201002:14Not Applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

User accounts are locked out after a certain number of bad logon attempts.

For a locked-out account, the following error messages are generated by KDC.

Generic message:

(KDC_ERR_CLIENT_REVOKED)

Extended, specific error message:

(STATUS_ACCOUNT_LOCKED_OUT, STATUS_ACCOUNT_DISABLED, STATUS_INVALID_LOGON_HOURS, STATUS_LOGIN_TIME_RESTRICTION,STATUS_LOGIN_WKSTA_RESTRICTION, STATUS_ACCOUNT_EXPIRED).
For information about software update terminology, see Description of the standard terminology that is used to describe Microsoft software updates .

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Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_c7dbe0bd4a7cdc0bb1289388edc11708_31bf3856ad364e35_6.1.7601.22313_none_d4616d19b594862c.manifest
File versionNot Applicable
File size724
Date (UTC)01-May-2013
Time (UTC)20:21
PlatformNot Applicable
File nameAmd64_microsoft-windows-k..distribution-center_31bf3856ad364e35_6.1.7601.22313_none_ea664dc6c3ff15cc.manifest
File versionNot Applicable
File size35,825
Date (UTC)01-May-2013
Time (UTC)05:44
PlatformNot Applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbbug, kbsurveynew

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Article Info
Article ID : 2837148
Revision : 1
Created on : 1/7/2017
Published on : 6/12/2013
Exists online : False
Views : 161