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You cannot add VHD files to Hyper-V virtual machines in Windows Server 2012


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You create some failover cluster nodes on computers that are running Windows Server 2012.
  • You have the Hyper-V server role installed on the cluster nodes.
  • You create virtual machines on one cluster node, and you configure the virtual machines as cluster resources.
  • You create multiple Cluster Shared Volume (CSV) resources and create one Virtual Hard Disk (VHD) file in each CSV.
  • You use Hyper-V Manager to try to add the VHD files to the virtual machines.
In this scenario, you cannot add the VHD files to the virtual machines. Additionally, you receive an error message that resembles the following:
Error applying Hard Drive changes

'Virtual machine' failed to add resources to 'virtual machine'

Cannot add 'C:\ClusterStorage\Volume3\Test3.vhdx'. The disk is already connected to the virtual machine 'virtual machine'. (Virtual machine ID virtual machine ID)

'Virtual machine' failed to add resources. (Virtual machine ID virtual machine ID)

Cannot add 'C:\ClusterStorage\Volume3\Test3.vhdx'. The disk is already connected to the virtual machine 'virtual machine'. (Virtual machine ID virtual machine ID)

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Cause

This issue occurs because multiple CSV volumes have the same 0000-0000 serial number. Therefore, the VHD files on different volumes are recognized as the same file.

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Resolution

This hotfix is also available at Microsoft Update Catalog.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.





Windows Server 2012 file information notes
Important Windows 8 hotfixes and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    VersionProductMilestoneService branch
    6.2.920 0.20 xxxWindows Server 2012RTMLDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Csvfs.sys6.2.9200.20686624,12811-Apr-201322:15x64


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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2012

Additional files for all supported x64-based versions of Windows Server 2012
File nameAmd64_be7068658c4f7bb9f0655692a7334a23_31bf3856ad364e35_6.2.9200.20686_none_c24c32857537737b.manifest
File versionNot applicable
File size718
Date (UTC)12-Apr-2013
Time (UTC)22:57
PlatformNot applicable
File nameAmd64_microsoft-windows-f..rcluster-csvfs-core_31bf3856ad364e35_6.2.9200.20686_none_2f8c1ecf024dcaff.manifest
File versionNot applicable
File size3,087
Date (UTC)12-Apr-2013
Time (UTC)01:17
PlatformNot applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, kberrmsg

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Article Info
Article ID : 2836402
Revision : 1
Created on : 1/7/2017
Published on : 5/15/2013
Exists online : False
Views : 248