Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"The service isn't activated" status message when you try to connect to a mobile broadband network in Windows 8


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows 8.
  • You have a CDMA mobile broadband network adapter that supports multiple mobile virtual network operators (MVNOs).
  • You try to connect to a mobile broadband network by clicking a specific operator on the Networks charm. You try to connect to the network by using a device that is not activated yet.
    Note You expect Windows to download the operator's application automatically so that you can then activate the device by using the application.
In this situation, the Mobile Broadband Account Experience (MBAE) is negatively affected. For example, the icon of the provider is not displayed. Additionally, you receive the following status message from the Networks charm:
The service isn't activated.
Contact operator name to activate the service.

Note
This issue occurs when the network connection is not the first network connection that the system creates a device node for. If it is the first network connection that the system creates a device node for, the metadata is still downloaded.

↑ Back to the top


Cause

This issue occurs because MVNO does not provide the subscriber ID for CDMA devices that are not activated yet.

The system creates a mobile account device node for each provider. This is uniquely distinguished by either a subscriber ID or an equipment ID, which is used as an identifier for CDMA networks. When you click a new operator on the Networks charm, a device node is either created or updated, depending on whether a device node exists that has the same identifier. The system then downloads the metadata for the selected network. The metadata is only downloaded when a device node is created.

Note The metadata is also downloaded when a device node is re-enumerated, such as when you press F5 in the Devices and Printers dialog box.

If the device does not report subscriber IDs when switching providers, the system uses the equipment ID to create and identify the device node. Therefore, only one device node is created for the device. The metadata is downloaded and parsed for the previous provider. Therefore, all the information in the metadata is not collected by the system. As a side effect, the operator's application is not downloaded, and the application link is not displayed on the Networks charm. This also results in an unconnectable state, as operators usually provide an option to activate their devices by using their applications.

↑ Back to the top


Resolution

To resolve this issue, install update rollup 2855336, or install the hotfix that is described in this article.

Update information

For more information about how to obtain this update rollup package, click the following article number to view the article in the Microsoft Knowledge Base:
2855336 Windows RT, Windows 8, and Windows Server 2012 update rollup: July 2013

Hotfix information

After you install the hotfix, the following behavior is improved:
  • Metadata is not immediately downloaded when switching providers.
  • Metadata cannot be parsed when the device is not activated and does not report subscriber ID.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 8.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.





Windows 8 file information notes
Important Windows 8 hotfixes and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    VersionProductMilestoneService branch
    6.2.920 0.16 xxxWindows 8 RTMGDR
    6.2.920 0.20 xxxWindows 8 RTMLDR
  • GDR service branches contain only those fixes that are widely released to address widespread, extremely important issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 8" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 8
File nameFile versionFile sizeDateTimePlatform
Devicesetupmanager.dll6.2.9200.16611161,79215-May-201322:36x86
Devicesetupmanager.dll6.2.9200.20716161,79215-May-201322:35x86
Mbaeparsertask.exe6.2.9200.1661167,58415-May-201322:37x86
Mbaeparsertask.exe6.2.9200.2071667,58415-May-201322:35x86
For all supported x64-based versions of Windows 8
File nameFile versionFile sizeDateTimePlatform
Devicesetupmanager.dll6.2.9200.16611207,87215-May-201322:34x64
Devicesetupmanager.dll6.2.9200.20716207,87216-May-201300:53x64
Mbaeparsertask.exe6.2.9200.1661180,89615-May-201322:36x64
Mbaeparsertask.exe6.2.9200.2071680,89616-May-201300:54x64


↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Additional file information

Additional file information for Windows 8

Additional files for all supported x86-based versions of Windows 8
File nameUpdate-bf.mum
File versionNot Applicable
File size2,193
Date (UTC)17-May-2013
Time (UTC)06:23
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,231
Date (UTC)17-May-2013
Time (UTC)06:23
PlatformNot Applicable
File nameX86_513a80366580826d0b0df68625cc65c5_31bf3856ad364e35_6.2.9200.20718_none_fe256a230a05dae0.manifest
File versionNot Applicable
File size706
Date (UTC)17-May-2013
Time (UTC)06:23
PlatformNot Applicable
File nameX86_64a8e82a492aa63c76dd2f36cf018af7_31bf3856ad364e35_6.2.9200.20718_none_7697a268afb78314.manifest
File versionNot Applicable
File size727
Date (UTC)17-May-2013
Time (UTC)06:23
PlatformNot Applicable
File nameX86_a7565b133a28d2a07c2d39afb94931ab_31bf3856ad364e35_6.2.9200.16613_none_6468a8d43a07772c.manifest
File versionNot Applicable
File size727
Date (UTC)17-May-2013
Time (UTC)06:23
PlatformNot Applicable
File nameX86_f73add5daff4212599150622a533cc4e_31bf3856ad364e35_6.2.9200.16613_none_cceac39f91508731.manifest
File versionNot Applicable
File size706
Date (UTC)17-May-2013
Time (UTC)06:23
PlatformNot Applicable
File nameX86_microsoft-windows-devicesetupmanager_31bf3856ad364e35_6.2.9200.16613_none_6ffdc657914c1122.manifest
File versionNot Applicable
File size20,137
Date (UTC)17-May-2013
Time (UTC)06:23
PlatformNot Applicable
File nameX86_microsoft-windows-devicesetupmanager_31bf3856ad364e35_6.2.9200.20718_none_708c6494aa652f9f.manifest
File versionNot Applicable
File size20,137
Date (UTC)17-May-2013
Time (UTC)06:23
PlatformNot Applicable
File nameX86_microsoft-windows-m..erience-parser-task_31bf3856ad364e35_6.2.9200.16613_none_c70821523cc68749.manifest
File versionNot Applicable
File size24,161
Date (UTC)17-May-2013
Time (UTC)06:23
PlatformNot Applicable
File nameX86_microsoft-windows-m..erience-parser-task_31bf3856ad364e35_6.2.9200.20718_none_c796bf8f55dfa5c6.manifest
File versionNot Applicable
File size24,161
Date (UTC)17-May-2013
Time (UTC)06:23
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows 8
File nameAmd64_00c00018b67dbe87901373dfa5114592_31bf3856ad364e35_6.2.9200.20718_none_e58753937ea5a394.manifest
File versionNot Applicable
File size710
Date (UTC)17-May-2013
Time (UTC)06:27
PlatformNot Applicable
File nameAmd64_3dc24f7ce018fc6eab1b7303a84b6ad8_31bf3856ad364e35_6.2.9200.16613_none_b67ef2dfe83535d0.manifest
File versionNot Applicable
File size710
Date (UTC)17-May-2013
Time (UTC)06:27
PlatformNot Applicable
File nameAmd64_4b46825be06a73408b70939d799b212f_31bf3856ad364e35_6.2.9200.20718_none_d9aa0c87efb81159.manifest
File versionNot Applicable
File size731
Date (UTC)17-May-2013
Time (UTC)06:27
PlatformNot Applicable
File nameAmd64_5a7cfc53ab11cb097b90d9ba6c476e42_31bf3856ad364e35_6.2.9200.16613_none_c3db9abf3ee46b32.manifest
File versionNot Applicable
File size731
Date (UTC)17-May-2013
Time (UTC)06:27
PlatformNot Applicable
File nameAmd64_microsoft-windows-devicesetupmanager_31bf3856ad364e35_6.2.9200.16613_none_cc1c61db49a98258.manifest
File versionNot Applicable
File size20,141
Date (UTC)17-May-2013
Time (UTC)06:28
PlatformNot Applicable
File nameAmd64_microsoft-windows-devicesetupmanager_31bf3856ad364e35_6.2.9200.20718_none_ccab001862c2a0d5.manifest
File versionNot Applicable
File size20,141
Date (UTC)17-May-2013
Time (UTC)06:28
PlatformNot Applicable
File nameAmd64_microsoft-windows-m..erience-parser-task_31bf3856ad364e35_6.2.9200.16613_none_2326bcd5f523f87f.manifest
File versionNot Applicable
File size24,165
Date (UTC)17-May-2013
Time (UTC)06:28
PlatformNot Applicable
File nameAmd64_microsoft-windows-m..erience-parser-task_31bf3856ad364e35_6.2.9200.20718_none_23b55b130e3d16fc.manifest
File versionNot Applicable
File size24,165
Date (UTC)17-May-2013
Time (UTC)06:28
PlatformNot Applicable
File nameUpdate-bf.mum
File versionNot Applicable
File size2,413
Date (UTC)17-May-2013
Time (UTC)06:27
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,456
Date (UTC)17-May-2013
Time (UTC)06:27
PlatformNot Applicable

↑ Back to the top


Keywords: kb, kbqfe, kbautohotfix, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

↑ Back to the top

Article Info
Article ID : 2836380
Revision : 1
Created on : 1/7/2017
Published on : 7/9/2013
Exists online : False
Views : 247