Items are missing from search results when Microsoft 365 users search their mailbox in Outlook on the web
Original KB number: 2835179
Problem
When Microsoft 365 users search their mailbox in Outlook on the web (formerly known as Outlook Web App), they notice that lots of messages are missing from the search results. Additionally, gaps may be present in the date range of items that are returned in the search results.
Cause
This problem occurs if the search returns more than 1028 items.
Solution
Take any of the following actions:
- Reduce the scope of the search to only specific folders or subfolders.
- Use more-specific search terms.
- Use Microsoft Outlook in Cached Exchange Mode to search the mailbox.
Note
If you use Outlook to search the Online Archive folder, you will receive the same limited search results as Outlook on the web. This is because Outlook accesses the Online Archive folder in Online Mode.
More information
Be aware that, to reduce the time to show search results, users may receive only a subset of the results. In this scenario, scroll down the results list to view additional results up to the limit of 1028 items.
For more information, see Search Mail and People in Outlook Web App.
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