Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

User receives SMB change notifications from a subfolder that the user does not have permission to access in Windows 7 SP1 or Windows Server 2008 R2 SP1


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a shared folder on a computer that is running Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 SP1.
  • A user (user A) maps a network drive to the shared folder. Therefore, user A can receive change notifications from the shared folder.
  • Another user (user B) changes a file in a subfolder or adds a file to a subfolder that user A does not have permission to access. The subfolder is in the shared folder.
In this scenario, user A receives Server Message Block (SMB) change notifications from the subfolder.

Notes
  • The expected behavior is that user A does not receive change notifications from the subfolder.
  • Change notifications are sent when any of the following activities occur:
    • A user creates files or folders.
    • A user changes existing files or folders.
    • A user reads the documents that are temporarily written to the shared folder or automatically saved or locked in the shared folder.

↑ Back to the top


Cause

This issue occurs because the SMB protocol cannot modify change notification requests for each user.

↑ Back to the top


Resolution

Hotfix information

This hotfix can resolve the issue that is described in this Knowledge Base article only after you remove the "bypass traverse checking" (SeChangeNotifyPrivilege) permission for the user. However, after you remove the permission, the computer may experience some performance issues. You can monitor the system performance before and after you remove the permission to better understand the effect of the performance issues on your computer.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 SP1 or Windows Server 2008 R2 SP1.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760 1.22xxxWindows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Srv.sys6.1.7601.22296311,80810-Apr-201303:04x86
Srv2.sys6.1.7601.22296313,34410-Apr-201303:04x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Srv.sys6.1.7601.22296467,45610-Apr-201302:59x64
Srv2.sys6.1.7601.22296409,08810-Apr-201302:58x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Srv.sys6.1.7601.222961,028,60810-Apr-201302:26IA-64
Srv2.sys6.1.7601.22296796,67210-Apr-201302:26IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_a0f2fb620dcff5350c1dc436f0891f78_31bf3856ad364e35_6.1.7601.22296_none_181dddba4104725b.manifest
File versionNot applicable
File size700
Date (UTC)12-Apr-2013
Time (UTC)14:28
PlatformNot applicable
File nameX86_b41f98e3d7192b6be2f0c1f9dcc27744_31bf3856ad364e35_6.1.7601.22296_none_456c5fb7e6fc072e.manifest
File versionNot applicable
File size700
Date (UTC)12-Apr-2013
Time (UTC)14:28
PlatformNot applicable
File nameX86_microsoft-windows-smbserver-v1_31bf3856ad364e35_6.1.7601.22296_none_dc33d2e56e1287e5.manifest
File versionNot applicable
File size3,022
Date (UTC)10-Apr-2013
Time (UTC)05:46
PlatformNot applicable
File nameX86_microsoft-windows-smbserver-v2_31bf3856ad364e35_6.1.7601.22296_none_dc2902f96e1aa3d6.manifest
File versionNot applicable
File size2,655
Date (UTC)10-Apr-2013
Time (UTC)05:41
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_3895efb0a7aee4a8b22c1b1d7ee21d12_31bf3856ad364e35_6.1.7601.22296_none_e5f562d5d1e9890f.manifest
File versionNot applicable
File size704
Date (UTC)12-Apr-2013
Time (UTC)14:28
PlatformNot applicable
File nameAmd64_419e5a522bd7c8fe74afdda344535a21_31bf3856ad364e35_6.1.7601.22296_none_e5d14fd266c99927.manifest
File versionNot applicable
File size704
Date (UTC)12-Apr-2013
Time (UTC)14:28
PlatformNot applicable
File nameAmd64_microsoft-windows-smbserver-v1_31bf3856ad364e35_6.1.7601.22296_none_38526e69266ff91b.manifest
File versionNot applicable
File size3,026
Date (UTC)10-Apr-2013
Time (UTC)05:48
PlatformNot applicable
File nameAmd64_microsoft-windows-smbserver-v2_31bf3856ad364e35_6.1.7601.22296_none_38479e7d2678150c.manifest
File versionNot applicable
File size2,657
Date (UTC)10-Apr-2013
Time (UTC)05:47
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_6138da9bc85aa3188d651323dfa81f52_31bf3856ad364e35_6.1.7601.22296_none_91f35f0f91392b76.manifest
File versionNot applicable
File size702
Date (UTC)12-Apr-2013
Time (UTC)14:28
PlatformNot applicable
File nameIa64_e086e41635a5db35e930bad25f4ec559_31bf3856ad364e35_6.1.7601.22296_none_a3bf4b580970e504.manifest
File versionNot applicable
File size702
Date (UTC)12-Apr-2013
Time (UTC)14:28
PlatformNot applicable
File nameIa64_microsoft-windows-smbserver-v1_31bf3856ad364e35_6.1.7601.22296_none_dc3576db6e1090e1.manifest
File versionNot applicable
File size3,024
Date (UTC)10-Apr-2013
Time (UTC)05:31
PlatformNot applicable
File nameIa64_microsoft-windows-smbserver-v2_31bf3856ad364e35_6.1.7601.22296_none_dc2aa6ef6e18acd2.manifest
File versionNot applicable
File size2,656
Date (UTC)10-Apr-2013
Time (UTC)05:30
PlatformNot applicable

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, KB2831013

↑ Back to the top

Article Info
Article ID : 2831013
Revision : 4
Created on : 5/28/2013
Published on : 5/28/2013
Exists online : False
Views : 316