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FIX: Some newly added access accounts for a package may be missing on child sites in Systems Center Configuration Manager 2007 Service Pack 2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You create a package in Microsoft System Center Configuration Manager 2007 Service Pack 2 (SP2).
  • You assign multiple access accounts for the package.
  • You update the package multiple times by adding additional access accounts.

In this scenario, more than 20 percent of the access accounts that you added to the package may be missing on child sites.

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Cause

This problem occurs because Configuration Manager starts distributing a package to the child site before the Configuration Manager provider processes all the actions for the package.

In System Center Configuration Manager 2007, when multiple actions are run on a package in quick succession, one notification for each action is entered in the PkgNotification table in the Microsoft SQL Server database. For example, if you add 100 more distribution points to a package, 100 entries for the package are entered in the PkgNotification table. When the first notification is received, the SQL Monitor service notifies Configuration Manager to process the action.

When Configuration Manager starts, it queries for all package objects that have a pending action. Then, Configuration Manager processes these actions in the order in which they were received. If these actions are not processed in the correct order, the child site may incorrectly process the actions that are specified by the parent site. Therefore, the child site will not be synchronized with the parent site.

Notifications for packages are generated when you perform any of the following actions:
  • Add or remove a package
  • Change the properties of a package
  • Update a package
  • Add, remove, or update a distribution point
  • Add, remove, or change a program
  • Add, remove, or change an access account for the package

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have System Center Configuration Manager 2007 SP2 installed.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart information

You do not have to restart the computer after you apply this hotfix.

Note We recommend that you close the Configuration Manager Administration Console before you install this hotfix package.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Basesvr.dll4.0.6487.22311,746,58401-Feb-201019:50x86


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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbautohotfix, kbqfe, kbfix, kbhotfixserver, kbsurveynew, kbexpertiseinter, kb

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Article Info
Article ID : 2830195
Revision : 1
Created on : 1/7/2017
Published on : 4/22/2013
Exists online : False
Views : 208