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"0x000000D1" error in Srv2.sys on a server that's running Windows Server 2008 R2 Service Pack 1


View products that this article applies to.

Symptoms

A server that's running Windows Server 2008 R2 Service Pack 1 (SP1) crashes randomly in the Srv2.sys file process, and you receive a Stop error message that resembles the following:

0x000000D1 (parameter1, parameter2, parameter3, parameter4)


Notes
  • This Stop error describes a DRIVER_IRQL_NOT_LESS_OR_EQUAL issue.
  • The parameters in this error message vary, depending on the configuration of the server.
  • Not all "0x000000D1" errors are caused by this issue.

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Cause

This issue occurs because of a race condition in the Srv2.sys process.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows Server 2008 R2 Service Pack 1 installed to apply this hotfix. For information about how to obtain a Windows Server 2008 R2 service pack, see�Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2.

Restart information

You�have to restart the server after you apply this hotfix.

Replacement information

This hotfix does not replace any previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductMilestoneService branch
    6.1.7601.22xxxWindows Server 2008 R2SP1LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Srv2.sys6.1.7601.22314409,08802-May-201302:56x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Srv2.sys6.1.7601.22314797,18402-May-201302:28IA-64


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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, see�Standard terminology that's used to describe Microsoft software updates.

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Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_microsoft-windows-smbserver-v2_31bf3856ad364e35_6.1.7601.22314_none_389c1f2f2638fffd.manifest
File versionNot Applicable
File size2,657
Date (UTC)02-May-2013
Time (UTC)05:43
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_microsoft-windows-smbserver-v2_31bf3856ad364e35_6.1.7601.22314_none_dc7f27a16dd997c3.manifest
File versionNot Applicable
File size2,656
Date (UTC)02-May-2013
Time (UTC)05:11
PlatformNot Applicable

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Keywords: kbmdd, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbbug, KB2826628

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Article Info
Article ID : 2826628
Revision : 4
Created on : 10/9/2014
Published on : 10/9/2014
Exists online : False
Views : 318