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XCON: Large Number of 5.0.0 NDRs in a Routing Group


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Symptoms

When Exchange 2000 Server reloads the e-mail routing table, e-mail messages may generate NDRs (non-delivery reports). Users may receive an NDR that is similar to the following NDR:
From:����system_administrator
To:������user
Subject:�Undeliverable:

Your message did not reach some or all of the intended recipients.

The following recipient(s) could not be reached:

user@domain.com on 1/5/2001 2:29 PM

The e-mail system was unable to deliver the message, but did not report a specific reason. Check the address and try again. If it still fails, contact your system administrator.
<server_name.domain.com #5.0.0>
When this problem occurs, a large number of NDRs are sent back to users. When you look at the WinRoute data, there are missing connectors. This problem occurs in a single routing group. This problem typically occurs when there is not a pure Exchange 2000 to Exchange 2000 Routing Group connector.

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Cause

This problem can occur if the Exchange 2000 routing engine encounters an error when communicating with Active Directory. Because of this error, the routing engine does not update the routing table.

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Resolution

To resolve this problem, obtain the latest service pack for Microsoft Exchange 2000 Server. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
301378 XGEN: How to Obtain the Latest Exchange 2000 Server Service Pack
The English version of this fix should have the following file attributes or later:

Component: Transport Core

File nameVersion
Mtaroute.dll6.0.4418.57
Phatq.dll6.0.4418.57
Reapi.dll6.0.4418.57
Resvc.dll6.0.4418.57
Tranmsg.dll6.0.4418.57

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Status

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server. This problem was first corrected in Microsoft Exchange 2000 Server Service Pack 1.

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More information

If an error occurs when the Exchange 2000 routing engine is communicating with Active Directory, Exchange 2000 may ignore available routes. When the routing table is rebuilt in Exchange 2000, the current table is removed and then the new table is reloaded. If a communication error occurs between Exchange 2000 and Active Directory while the current table is being removed and the new table is being reloaded, Exchange 2000 is without a routing table, which causes e-mail messages to generate NDRs. This behavior continues until the routing is successfully reloaded from Active Directory. To resolve this problem, the following changes were made in the fix that is described in the "Resolution" section of this article:
  • An error message in the following format is logged when this problem occurs:
    EVENT ID: 929
    TYPE: ERROR
    DESCRIPTION: Failed in reading Connector's DS Info
  • Messages queue up in the Currently Unreachable queue instead of generating NDRs immediately.
  • The routing code logic is changed so that when Exchange 2000 attempts to reload the routing table, Exchange 2000 verifies that it can obtain the new routing table before Exchange 2000 destroys the old routing table. If an error occurs during this process, Exchange 2000 logs the 929 error message and keeps the current routing table.
For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
281382 XCON: How to Use the WinRoute Tool

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Keywords: KB282506, kbhotfixserver, kbqfe, kbfix, kbexchange2000presp1fix, kberrmsg, kbbug

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Article Info
Article ID : 282506
Revision : 5
Created on : 2/20/2007
Published on : 2/20/2007
Exists online : False
Views : 335