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Oplock break requests are ignored by a Windows 7-based or Windows Server 2008 R2-based client


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You use an application to open executable files over the network from a client computer that is running Windows 7 or Windows Server 2008 R2.
  • This application also opens more files that enable opportunistic locking (oplock) over the network.
  • Another process tries to access a shared file that the application already opened over the network.
  • The server requests that the client computer break the oplock.
In this scenario, client computer does not break the oplock. Therefore, the shared file remains open on the server, and other clients cannot use that file.

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Cause

This issue occurs because the memory manager on the client computer holds executable objects and does not close them. However, the server considers the executable objects to be closed and reuses the file ID for another new file. This causes a file ID collision. Therefore, when the oplock break request is issued, the client computer processes the previous executable object instead of the new file.

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Resolution

Hotfix information

The hotfix for this issue is included in update 2732673. To resolve the issue, install update 2732673 from the following Microsoft Knowledge Base article:
2732673 "Delayed write failed" error message when .pst files are stored on a network file server that is running Windows Server 2008 R2

Prerequisites

To apply this hotfix, you must be running Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 SP1.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kb, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

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Article Info
Article ID : 2824408
Revision : 1
Created on : 1/7/2017
Published on : 8/16/2013
Exists online : False
Views : 161