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FIX: "Unknown" error message for suspended EDI message instances in BizTalk Server 2009


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Symptoms

Consider the following scenario:
  • You use the native Electronic Data Interchange (EDI) components in Microsoft BizTalk Server 2009 to receive EDI messages.
  • You receive incoming EDI messages that use multiple schemas. For example, an incoming message uses the 837 Professional 5010 Schema.
  • The message fails at the EDI pipeline, and the EDI message instance is suspended.

In this scenario, no helpful error information is generated. However, an error message that resembles the following is logged in the BizTalk Server Administration Console event log:

An output message of the component "Unknown " in receive pipeline "Microsoft.BizTalk.Edi.DefaultPipelines.EdiReceive, Microsoft.BizTalk.Edi.EdiPipelines, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" is suspended due to the following error:

Unknown.

The sequence number of the suspended message is 1.

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Cause

This issue occurs because of a problem in the subdocument break-splitting logic that is used in multiple schemas.

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Resolution

Cumulative update information

The fix for this issue is included in Cumulative Update 7 for BizTalk Server 2009.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kb, kbqfe, kbfix, kbexpertiseinter, kbsurveynew, kbbug, kbnotautohotfix

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Article Info
Article ID : 2823189
Revision : 1
Created on : 1/7/2017
Published on : 11/30/2014
Exists online : False
Views : 387