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Disconnected sessions retain the original <clientname> variable


View products that this article applies to.

This article was previously published under Q281981

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Symptoms

When you reconnect to a disconnected Terminal Services session on a different computer from the one on which you originally established the connection, the clientname variable retains the computer name of the computer on which you created the original session.

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Cause

This problem occurs because when you reconnect to a disconnected session, Terminal Services does not verify whether the client computer has changed.

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Resolution

Windows XP hotfix information

A supported hotfix is now available from Microsoft. However, this hotfix is intended to correct only the problem that this article describes. Apply this hotfix only to systems that are experiencing this specific problem.

To resolve this problem, submit a request to Microsoft Online Customer Services to obtain the hotfix. To submit an online request to obtain the hotfix, visit the following Microsoft Web site:Note If additional issues occur or any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. To create a separate service request, visit the following Microsoft Web site:

Prerequisites

You must have Windows XP Service Pack 2 installed to apply this hotfix.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with SP2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Termsrv.dll5.1.2600.3501296,44826-Dec-200813:51x86
Windows XP with SP3, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Termsrv.dll5.1.2600.5733296,44826-Dec-200813:45x86

Windows Server 2003 hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Windows Server 2003 installed to apply this hotfix.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

How to enable the hotfix

You have to manually create and configure the UpdateClientNameOnReconnect registry entry on the Windows 2003-based computer if the hotfix does not automatically create and configure this registry entry. To create and configure the registry entry manually, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. In the details pane, type UpdateClientNameOnReconnect, and then press ENTER.
  5. Right-click UpdateClientNameOnReconnect, and then click Modify.
  6. In the Edit DWORD Value dialog box, under Base, click Hexadecimal.
  7. In the Value data box, type 1, and then click OK.
  8. Exit Registry Editor.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with SP1, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Termsrv.dll5.2.3790.2915246,78413-Apr-200713:46x86
Windows Server 2003 with SP2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Termsrv.dll5.2.3790.4059246,78413-Apr-200714:00x86
Windows Server 2003 with SP1, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Termsrv.dll5.2.3790.2915365,05612-Apr-200723:28x64
Windows Server 2003 with SP2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Termsrv.dll5.2.3790.4059365,56812-Apr-200723:33x64
Windows Server 2003 with SP1, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Termsrv.dll5.2.3790.2915698,88012-Apr-200723:28IA-64
Windows Server 2003 with SP2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Termsrv.dll5.2.3790.4059699,90412-Apr-200723:32IA-64

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Workaround

To resolve this problem, log off from the Terminal Services session, and then log back on so that you can re-establish the clientname variable from the new computer.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

Programs or scripts that rely on the clientname variable may not work if you establish a session on one computer, disconnect, then reconnect to that session from a different computer.

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Keywords: kbprb, kbtermserv

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Article Info
Article ID : 281981
Revision : 5
Created on : 1/6/2009
Published on : 1/6/2009
Exists online : False
Views : 540