Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

PRB: Moving Items Within Drive M of Exchange Can Remove Item Properties


View products that this article applies to.

This article was previously published under Q281673

↑ Back to the top


Symptoms

Items that are moved between stores using drive M: may lose Messaging Application Programming Interface (MAPI) and schema properties in the move. Contact, Task, and other special items may revert to regular messages or posts when they are moved manually.

↑ Back to the top


Cause

Using Windows Explorer to explore drive M: is only intended as a way to view items in the store. This is not intended as a way to manipulate or move items in the store. Because the file system is unaware of the MAPI and schema properties associated with the items, it cannot copy the properties when the items are moved. Items such as contacts or appointments may lose their associated properties when they are moved between stores using Windows Explorer.

↑ Back to the top


Resolution

The recommended method to move items between Exchange stores is to use MAPI, ActiveX Data Objects (ADO), or Web Distributing Authoring and Versioning (WebDAV) in code. Because these application programming interfaces (APIs) work directly with Exchange, they are aware of the associated properties.

↑ Back to the top


More information

With the Exchange Installable File System (EXIFS), it is possible to view items in an Exchange store by using Windows Explorer. Exchange 2000 creates a drive M: on the server that holds these items. Although it appears that you can move these items between folders by dragging and dropping them, this is not completely true. Although you can drag and drop the .eml files that represent these items, you may lose important properties on these items.

Steps to Reproduce the Issue

  1. Using Microsoft Outlook, create a contact named "Testcontact" in the Contact folder of a mailbox.
  2. Using Outlook, create a new Contact folder named "MyContacts" under Public Folders/All Public Folders.
  3. Using Windows Explorer, browse to M:\Domain\MBX\Mailbox\Contacts.
  4. Right-click Testcontact.eml, and the click Copy.
  5. Browse to M:\Domain\Public Folders\MyContacts.
  6. From the Edit menu, click Paste to paste the contact.
  7. Using Outlook, examine the new item in the MyContacts folder. Note that most of the original Contact's properties are absent.

↑ Back to the top


Keywords: KB281673, kbprb, kbmsg

↑ Back to the top

Article Info
Article ID : 281673
Revision : 5
Created on : 2/22/2007
Published on : 2/22/2007
Exists online : False
Views : 241