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ADUC displays unreadable text in an error message when you add a user to a group in Windows Vista, Windows 7, Windows Server 2008 or Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have Remote Server Administration Tools (RSAT) installed on a computer that is running one of the following operating systems:
    • Windows Vista
    • Windows Server 2008
    • Windows 7
    • Windows Server 2008 R2
  • A user tries to add another user to one or more groups by using Active Directory User and Computers (ADUC). For example, you open the Properties tab of a user account, and then you try to add the user to a group in the Member of tab.
  • The user does not have the required permissions to the groups.
In this scenario, you receive an error message that states the group cannot be changed because of the lack of permissions. However, the group name is unreadable and the error message resembles the following:
You do not have permission to modify the group §=9$.
Note The text §=9$, may vary. Sometimes, the unreadable text may contain eastern language characters, such as Chinese, Korean or Japanese characters.

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Cause

This issue occurs because the text for the group name is not passed correctly to the message box in Windows.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008 SP2
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2 SP1
For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:

935791 How to obtain the latest Windows Vista service pack

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix if ADUC is not running.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information

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Workaround

To work around the issue, uses one of the following methods:
  • Open the Properties tab of the group that you want to add the user account into, and then add the user account in the Member tab.
  • Add or remove each membership individually to determine the group that has failed.
  • Use the RSAT tools for Windows 8.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Additional file information

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

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Article Info
Article ID : 2815860
Revision : 1
Created on : 1/7/2017
Published on : 5/15/2013
Exists online : False
Views : 242