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FIX: BizTalk 2010 Accelerator for RosettaNet cannot transmit 3A4 confirmation response message


View products that this article applies to.

This article applies to:
  • Microsoft BizTalk 2010 Accelerator for RosettaNet (BTARN)

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Symptoms

In Microsoft BizTalk Server 2010, you use BTARN to process RosettaNet Implementation Framework (RNIF) messages from a partner. In this situation, you cannot transmit a Partner Interface Process (PIP) 3A4 confirmation response message to the partner. Additionally, you may receive an error message that resembles the following from the partner application:

System.Net Information: 0 : [8792] Connection#56086591 - Received status line: Version=1.1, StatusCode=400, StatusDescription=Internal Server Errror: Invocation: java.lang.StringIndexOutOfBoundsException: String index out of range: -2003.

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Cause

This issue occurs because BTARN constructs the 3A4 confirmation response message with the same InstanceIdentifier value in the following nodes:
  • "\ServiceHeader\ProcessControl\TransactionControl\ActionControl\ActionIdentity\InstanceIdentifier"
  • "\ServiceHeader\ProcessControl\TransactionControl\ActionControl\InResponseTo\ActionIdentity\InstanceIdentifier"

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.


Prerequisites

To apply this hotfix, you must have the following software installed:
  • Microsoft BizTalk Server 2010
  • Microsoft BizTalk 2010 Accelerator for RosettaNet

Restart requirement

You do not have to restart your computer after applying this hotfix. However, you must restart Internet Information Services (IIS) and BizTalk Host Instance services.

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File Information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Microsoft.solutions.btarn.configurationmanager.dll3.9.602.2268,53606-Feb-201313:13x86

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More Information

For information about service packs and cumulative updates for BizTalk Server, click the following article number to view the article in the Microsoft Knowledge Base:
2555976 Service Pack and Cumulative Update list for BizTalk Server
For more information about BizTalk Server hot fixes, click the following article number to view the article in the Microsoft Knowledge Base:
2003907 Information about BizTalk hotfixes and service pack support
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kb16bitonly, kbexpertiseadvanced

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Article Info
Article ID : 2815109
Revision : 1
Created on : 1/7/2017
Published on : 3/22/2013
Exists online : False
Views : 258