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A Certificate Request That Uses a New Template Is Unsuccessful


IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry

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Symptoms

When you try to enroll for a certificate against an enterprise certification authority (CA), you may receive one of the following error messages:

Web enrollment:
Certificate Request Denied

Your certificate request was denied.

Contact your administrator for further information.

Certificate Request Wizard:
The certification authority denied your request. Unspecified error.

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Cause

This behavior may occur if the certificate enrollment request is using a recently-created certificate template. When a new template is added to the CA, the HKEY_CURRENT_USER cache is immediately updated but the HKEY_LOCAL_MACHINE cache is not immediately updated. The HKEY_LOCAL_ MACHINE cache is updated in the next 15 minutes if the CA or the domain controller are on the same computer, and in the next 10 minutes if the CA or the domain controller are in a distributed configuration.

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Resolution

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this behavior, if you cannot wait for the applicable length of time, you can manually update the certificate template cache. The cache for computer certificates is in
HKEY_LOCAL_MACHINE and the cache for user certificates is in HKEY_CURRENT_USER.
  • To force the cache update for a user certificate request, delete the following registry value from the client:
    HKEY_CURRENT_USER\Software\Microsoft\Cryptography\CertificateTemplateCache\Timestamp
To force the cache update for a computer certificate request:
  1. Delete the following registry value from the client:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\CertificateTemplateCache\Timestamp
  2. Delete the following registry value from the CA:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\CertificateTemplateCache\Timestamp
  3. Restart the Certificate Services on the CA.

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More Information

In addition to the preceding error message, the CA logs the following event message in the program log:

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Article Info
Article ID : 281260
Revision : 3
Created on : 4/20/2018
Published on : 4/20/2018
Exists online : False
Views : 137