Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Email message delivery is delayed on a Blackberry mobile device after you install Update Rollup 4 for Exchange Server 2010 SP2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install Update Rollup 4 for Microsoft Exchange Server 2010 SP2 in an environment that is running against a Blackberry Enterprise Server (BES).
  • The BES uses MAPI or Collaborative Data Objects (CDO) instead of Exchange Web Services (EWS) to communicate with Exchange servers.
  • A mailbox on a Blackberry mobile device contains many folders. For example, the mailbox contains more than 5000 folders.
In this scenario, you encounter one or more of the following issues:
  • Email message delivery to the mailbox on a BlackBerry mobile device is delayed.
  • It takes longer than expected to scan a folder hierarchy in the mailbox. For example, before you install Update Rollup 4 for Exchange Server 2010 SP2, a scan of a folder hierarchy takes about 5 minutes. After you install Update Rollup 4 for Exchange Server 2010 SP2, a scan of a folder hierarchy takes about 30 minutes to 1 hour.
  • The Microsoft Exchange Information Store process (Store.exe) on the Exchange Mailbox server uses excessive CPU resources.
  • Some BES event log entries are logged on the Exchange Mailbox server. Before you install Update Rollup 4 for Exchange Server 2010 SP2, few entries are logged, or no entries are logged.
  • Some events are logged in the BlackBerry Messaging Agent (MAGT) log. These events resemble the "Busy Working" threads that are described in the following article in the BlackBerry Knowledge Base:



↑ Back to the top


Cause

This issue occurs because the Exchange server creates a new admin session every time that the server tries to bind the delegate to each folder and retrieve folder properties for the delegate. Additionally, because the server sets a certain flag for each folder bind, a high-cost process flow occurs. Therefore, when BES requests the properties of many folders, the issue that is described in the "Symptoms" section occurs.

↑ Back to the top


Resolution

To resolve this issue, install the following update rollup:
2746164 Description of Update Rollup 6 for Exchange Server 2010 Service Pack 2
 
To reduce the effect of this issue, use the following methods:

Method 1

Install Exchange Server SP2 RU 6 when it becomes available.

Method 2

If there are less than 15 agents on the BES, add more agents to the BES. The maximum number of agents is 15. 

Method 3

Reduce the number of folders in the mailbox.

Method 4

If the mailbox contains many folders (for example, more than 500 folders), move the mailbox to its own instance of BESAgent.exe.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about the issue, click the following article numbers to view the articles in the Microsoft Knowledge Base:
2726897 Admin sessions are exhausted as a result of delegate access in an Exchange Server 2010 environment
2706690 Description of Update Rollup 4 for Exchange Server 2010 Service Pack 2

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.


↑ Back to the top


Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseinter, kb

↑ Back to the top

Article Info
Article ID : 2810616
Revision : 1
Created on : 1/7/2017
Published on : 2/12/2013
Exists online : False
Views : 306