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Can't display downloaded English Windows PowerShell 3.0 cmdlet Help files in a localized vesion of Windows 7, Windows Server 2008 R2, or Windows Server 2008 SP2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running a localized version of Windows 7, Windows Server 2008 R2, or Windows Server 2008 Service Pack 2 (SP2). 
  • You have update 2506143  installed on Windows 7-based or Windows Server 2008 R2-based computer. Or, you have update 2506146  installed on a Windows Server 2008 SP2-based computer. 
    Note You can use Windows PowerShell 3.0 after you have update 2506143 or update 2506146 installed on the computer.
  • You download the Windows PowerShell 3.0 cmdlet Help files in English (en-US) by using the Update-Help -UICulture en-US cmdlet.
  • You try to view the downloaded English (en-US) version of the Help files by using the Get-Help cmdlet.
In this scenario, the Get-Help cmdlet cannot locate the English (en-US) version of the Help files. Therefore, the cmdlet reverts to the auto-generated help content. 

Note The English (en-US) version of the Help files can be installed on localized versions of Windows by downloading the help content by using the Update-Help -UICulture en-US cmdlet.

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Cause

This issue occurs because the Get-Help cmdlet does not look for the Help files in the English (en-US) multilanguage subfolder. The English (en-US) version of the Help files are installed in the en-US multilanguage subfolder by using the Update-Help cmdlet. However, the Get-Help cmdlet cannot locate the Help files in the multilanguage subfolder for the current system language of the user. Therefore, the cmdlet incorrectly reverts to the auto-generated help content instead of looking in the English (en-US) multilanguage subfolder.

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Resolution

To resolve this issue, install the update that is described in update 2823180. For more information about how to obtain this update, click the following article number to view the article in the Microsoft Knowledge Base:
2823180 Update is available for Windows Management Framework 3.0 in Windows 7 SP1, Windows Server 2008 R2 SP1, or Windows Server 2008 SP2

Prerequisites

To apply this update, you must be running one of the following operating systems:
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2 Service Pack 1 (SP1)
  • Windows Server 2008 Service Pack 2 (SP2)
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

For more information about how to obtain a Windows 7 or a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kb, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

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Article Info
Article ID : 2809900
Revision : 1
Created on : 1/7/2017
Published on : 4/16/2013
Exists online : False
Views : 233